Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
I changed my desktop colors to 24 bit ... and once i restarted Red Hat 8.0 i recieved error that X cant start but it made a backup file callled ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Posts
    46

    changed my resolution and now X wont start???


    I changed my desktop colors to 24 bit ... and once i restarted Red Hat 8.0 i recieved error that X cant start but it made a backup file callled /etc/X11/XF86Config.backup???? do anyone know how to run the backup file????? what commands to type in root????

    *ps i have tried startx and redhat-config-xfree86 they were both unsuccessful in the probing, and i was unable to even reach the configuration screen setup.????

  2. #2
    Linux User
    Join Date
    Jul 2002
    Location
    Daytona Beach, FL
    Posts
    487
    start your compputer, once the X server finishes saying it can not start hit CTRL + ALT + F1

    and login as root, then type

    mv /etc/X11/XF86Config.backup /etc/X11/XF86Config

    then type

    init 5

    that will restore your previous X config file
    majorwoo

    Quiet brain, or I\'ll stab you with a Q-tip.

  3. #3
    Just Joined!
    Join Date
    Jan 2003
    Posts
    46
    ok im sorry i should have waited for a reply to my problem.. i think i kind of did something foolish now.

    I went to the directory that Xf86config.back up and rename it to xf86config. deleting the current xf86 file. I was hoping that when i ran xserver again it would acutally run the back up because it is not has the same name as the file it was trying to run before????

  4. #4
    Linux User
    Join Date
    Jul 2002
    Location
    Daytona Beach, FL
    Posts
    487
    that's what i told you to do, it should have restored your original config....

    you did

    cd /etc/X11/
    rm XF86Config
    mv XF86Config.backup Xf86Config

    right?

    That's the same thing, just more to type...
    did it work?

    Also, if you let X die it will popup a message i couldn't start the X server do you wish to run the config to fix it (select the box on the left) enter the root password, and it will try to fix it (usually works for me)
    majorwoo

    Quiet brain, or I\'ll stab you with a Q-tip.

  5. #5
    Just Joined!
    Join Date
    Jan 2003
    Posts
    46
    no i did it before you told me to and i did not use the mv command i used rename. what i did was i renamed the xf86config.backup to xf86.config by using the rename command. then after it renamed the file i tried to run startx and redhat-config after and they both failed at bring up the screen for me to make the changes???

  6. #6
    Just Joined!
    Join Date
    Jan 2003
    Posts
    46
    oh im sorry i dont think i ran init 5 though
    ill try it and report back my results

  7. #7
    Just Joined!
    Join Date
    Jan 2003
    Posts
    46
    i went to the exact directory and typed in init 5 (under root loging) and it did nothing .. i just skiped a line like it did something... then when trying to start xserver the following errors showed up


    error screens found but none have a useable configuration
    error vesa(0) no matching modes


    fatal IO error 104

    I typed init lower case and with a space between the word and the number 5... then i tried upercase neither did anything??

    I first deleted the original xf86config file
    and then with the Rename command i renamed xf86config.backup to xf86config. Then now i ran init 5 in the same directory and nothing changed I still cant get to the option wherei can changed the resolution.???? doesn anyone have ideas????

  8. #8
    Linux User
    Join Date
    Jul 2002
    Location
    Daytona Beach, FL
    Posts
    487
    have you tried rebooting? if all you did was change the 24 part, then renamed the backup to XF86Config you should be fine. Perhaps you have to init 3 then init 5

    (and yes tye just like this "init 3")

    i thought when redhat says its disablign teh X server for now it returned to runelevel 3, but i may be wrong. Try doing an

    init 3
    then
    init 5

    (good old fashioned reboot will do it too)
    majorwoo

    Quiet brain, or I\'ll stab you with a Q-tip.

  9. #9
    Just Joined!
    Join Date
    Jan 2003
    Posts
    46
    ok i tried that and that did not change it .. the a screen came up with messed up character i think it was trying to ask me somethign but the characters where unreadable....?

    I found out that XF86Config is a text file that could be edited.. I edited that part that i needed too when i ran startx it said error XF86Config. line one null section parse error with the words Files from Anaconda???

  10. #10
    Linux User
    Join Date
    Jul 2002
    Location
    Daytona Beach, FL
    Posts
    487
    ok, editing that file by hand can get you into troulble if you are not careful.

    reboot again and when it says stuff you cant read hit enter, (its asking if you want help fiixing the problem) then it will ask for the root password, and try to fix the problem for you.
    majorwoo

    Quiet brain, or I\'ll stab you with a Q-tip.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •