Find the answer to your Linux question:
Results 1 to 2 of 2
Hi, this would be my first post here, and I'm not too much of a linux newbie, but Im certianlly not a pro. (I did a quick search and didn't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2003
    Location
    /dev/null
    Posts
    25

    Dual booting Solaris and Linux


    Hi, this would be my first post here, and I'm not too much of a linux newbie, but Im certianlly not a pro. (I did a quick search and didn't see this posted before, but if there was, just point me in that direction).

    What I am trying to accomplish is a dual boot between Sun Solaris 9 and one of my linux distros (Either RH9, Mandrake 9, or Slackware 9.1. Most likely RH or Man). I have as of yet been completely unsuccessful in my attempts to do such. I'll explain briefly what I have tried, and then I'll open the floor for suggestions. Ok here we go...

    I used partition magic 8 to break up the drive into two partitions (its a 20GB drive) one would be divided up for the linux swap, boot and / partitions, the other would be broken up for Solaris' slice and / partitions.

    My first attempt was done with RH9, I installed LILO to the MBR (advice given to me by a more advanced linux user) and then installed RH to the second partition space. It installed fine, and there was enough space for the swap and / to function properly.

    Now it was time to install Solaris 9. I worked through the usual x86 version of solaris problems during installition, and told it what size I wanted the slice to be, and the rest for the /. It seemed to install fine, but when I rebooted I could only get into solaris.

    I took alook around for the lilo.conf file and couldn't find it (maybe thats just me tho...) and I didn't see any of the files from RH.

    So, I tried this again, only this time I put RH9 on the first partition and solaris on the second. Nothing worked this time.
    But both times, when I took alook at the partition configuration in partition magic (or Ranish which I used sometimes) it would give me an error code unique to partition magic, or in ranish the error was: "Inconsistant overlap" on the partitions.

    I made sure of every cluster to which I was assigining partitions and when I ran through both installs I didn't reuse space on the harddrive.
    So, thats basically what I have tried to do thus far, and I'm still unable to dualboot. Does anyone have any suggestions?

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    I vaguely remember something in Kernel config about recognising Sun partions, but that should only be for read/write access to them.


    not much help, I'm afraid

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •