Find the answer to your Linux question:
Results 1 to 4 of 4
Hi, I have two hard drives of size 40 and 120GB respectively. I installed winxp home on hd0. This WINXP home cd has a recovery image that comes with HP ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    3

    winxp and fedora 4 dual boot problem on hp pavilion box


    Hi,

    I have two hard drives of size 40 and 120GB respectively. I installed winxp home on hd0. This WINXP home cd has a recovery image that comes with HP pavilion box, creates two partiions 'winxp' on C and 'hp recovery image' on D drives. I have successfully installed fedora core 4 on the other hard drive hdb. While configuring grub, I have added windows hda2(to boot winxp).
    During booting, grub shows three entries in the menu
    1. linux fedora 4
    2. other ( i hope this is hp recovery)
    3. winxp

    options 1 and 2 works fine. When I choose to boot 'winxp' grub ends up with the following error
    installing winxp
    rootnoverify(hda2,1)
    chainloader +1

    and nothing happens.

    Can somebody help me on how to boot winxp along with the other options.

    Thanks
    madhu

  2. #2
    Linux Engineer
    Join Date
    Mar 2005
    Posts
    1,431
    Change this:
    Code:
    (hda2,1)
    to this:
    Code:
    (hd0,0)
    in your grub file. GRUB and the linux kernel uses different naming schemes for drives.

  3. #3
    Linux Newbie
    Join Date
    Mar 2005
    Location
    Minneapolis, MN
    Posts
    112
    If your Windows partition is located at hda2, then in GRUB-speak it should be

    Code:
    (hd0,1)
    --Dachnaz [Fuzzy Llama]

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    May 2004
    Location
    forums.gentoo.org
    Posts
    1,817
    Whether Windows is on (hd0,0) or (hd1,0) depends on which is the boot drive. I know it sounds weird, but I've seen it. The first drive Grub sees, Grub names (hd0), so if you boot to the second hard drive, the Primary master drive will be (hd1).

    puba123, you can try booting "by hand" without harming anything to help check things out. When you see the Grub menu, if you first highlight your Windows or "other" option and then press "e" for "edit", you will be able to change the lines in the script (like the "root" designation) and see if it works. Editing is not permanent, so you can try all you like untill you get it to work and then you can edit the config file to make it permanent.
    /IMHO
    //got nothin'
    ///this use to look better

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •