Find the answer to your Linux question:
Results 1 to 3 of 3
Hi All- I am having problem when I am trying to dual boot Fedora Core 4 with Windows 2K is as follows. I have Win 2k on my hard disk ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    1

    FC4 dual boot with Windows 2000


    Hi All-

    I am having problem when I am trying to dual boot Fedora Core 4 with Windows 2K is as follows.

    I have Win 2k on my hard disk and I have some place left for Linux. I have installed FC4 on it by doing 3 partitions one for "/", "/boot" and "swap".

    Drives are as follows
    /boot = /dev/hda9
    / = /dev/hda11
    swap = /dev/hda10.
    Windows is in /dev/hda1.

    During my installation of linux I am choosing the following options.
    1) Choose GRUB as the boot loader
    2) Choose Fedora (/dev/hda11) as the default operations system.
    3) Install boot loader on /dev/hda9

    After installation of linux, I am booting to linux with the first cd in Linux Rescue mode and copying the first 512 bytes of /dev/hda9 on to a floppy as a file called linux.bin.

    Then I am booting into windows and coping the file "linux.bin" on to my C drive and editing my boot.ini and incuding the path for the file linux.bin also.

    I am using the following commands for the above procedure
    # chroot /mnt/sysimage
    # cd /tmp
    # df ľk (just to make sure you are in right environment)
    # dd if=/dev/hda7 of=linux.bin bs=512 count=1
    Insert MS-DOS formatted floppy into the drive
    # mcopy linux.bin a:
    reboot and log in to into windows and copy the file "linux.bin" from the flopyy into "c:\" drive of windows.

    Now when I reboot my machine I am getting option for both the operating systems, and when I choose Linux, I get a promt with GRUB and after this nothing happens.

    I am not really sure why this is happening, I have installed linux prior to FC3 and I was sucessful with the above procedure, but this time it doesnt seem to work.

    I would really appreciate your inputs on this. It would be really great if some one can tell the steps to follow for dual booting FC4 with Win 2k.

    Following is my grub.conf
    #grub.conf generated by anaconda
    #
    #Note that you do not have to rerun grub after making chnages to this file
    #Notice: You have a /boot partition. This means that all kernel and initrd
    # paths are relative to /boot/, eg:
    # root (hd0,8)
    # Kernel /vmlinuz-version ro root=/dev/hda11
    # initrd /initrd-version.img
    #/boot=/dev/hda9
    default = 0
    timeout = 5
    splashimage = (hd0,8)/grub/splash.xpm.gz
    hiddenmenu
    title Fedora Core (2.6.11-1.1369_FC4)
    root (hd0,8)
    Kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=LABEL=/ rhgb quiet
    initrd /initrd-2.6.11-1.1369_FC4.img
    title other
    rootnoverify (hd0,0)
    chainloader +1


    Thank you
    Regards
    -A

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    my, you enjoy doing things the hard way.

    Okay, when your PC boots, it does a POST check (counts up the RAM and that sort of thing) and then looks for an operating system - OS - (or boot loader). It will look for the OS on disks in an order defined within the BIOS. So, with your setup, it will look on your first hard disk on your first IDE cable (ie. /dev/hda). It will look at the very first part of the hard disk, at an area called the master boot record (mbr). This is where most of us put grub.

    In your case it seems that it finds the microsoft boot stuff, which says "you can find a lovely OS on this first hard disk in the first partition" (ie. /dev/hda1 or C:\). Here, windows looks at boot.ini and gives you the choice of Windows or a real operating system, but to get to Linux you need to go through grub .

    This you choose and get a grub prompt, in glorious white on black.

    What to do next? Personally I'd just put grub on the mbr, and let grub look after all opertaing systems. But, for reasons of your own, you have decided to go through two boot loaders (boot.ini and then grub) to get to Linux. So, how to get past this. Have you read the tutorila about grub in the tutorial section of this forum?

    When you say that you get a grub prompt, what does it look like? grub or grub> ? If the later, then you need to tell grub where it can find its other files (these are in the folder called /boot/grub/ , which is on your /boot partition /dev/hda9 or in grub-speak (hd0,8 ) - it counts from zero, not one.

    My guess is that grub is looking at your / partition for the /boot/grub folder rather than your /boot partition. Have a look at the tutorial about re-installing grub (suggest that you boot into Linux via your CD and then get onto the /boot partition and do the re-install from there).

    In case you're unaware, you can have grub sit on your mbr and do the boot loading duties for both Linux and Windows. The windows boot.ini is not required.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    Code:
    Hi Nerderello
    
    At first thank you for your reply. I have couple of questions over here.
    At present my set up is like this
    
    /dev/hda1 :: C:/
    /dev/hda9 :: /boot
    /dev/hda10 :: swap
    /dev/hda11 :: /
    
    There are two steps when it comes to boot loader in the FC4 installation
    
    1) Choose the default OS
    Here I have two options
    a) Fedora Core (/dev/hda11)
    b) Other (/dev/hda1)
    2) Where I want to install the boot loader. (Advanced Options)
    Here I have two options
    a) MBR
    b) /dev/hda9
    
    Now please tell me what should be my options
    
    The concern I have is the large amount of data present in my Windows partitions, already I have installed grub at MBR and found my system not booting into either of the OS and I was just getting a prompt
    grub>
    
    your inputs are greatly appreciated
    
    Thank you
    I've included the above, as it was sent to me as a private message, and the idea of these forums is for everybody to share and see what is happening.

    Lindows, you ask what you should do next. First let me say that I cannot tell you what you should do. It's your PC, not mine. But I would suggest that you have a quick read of the grub tutorial (http://www.linuxforums.org/tutorials...ial-19999.html), it covers what you need to know.

    You say that you get a grub> prompt, which tells me that the first part of grub is being found and loaded. The subsequent parts of grub are files (with names like 'stage1.5' and 'stage2') that live in the /boot/grub/ folder. It is these files that grub isn't finding. The reason that it isn't finding these files is, I'm guessing, that it is looking on your '/dev/hda11 :: /' partition. It shouldn't be doing this, so, follow the instriuctions in the tutorial and do a re-instal of grub - telling it that the root device will be the /dev/hda9 hard disk partition, also know as (hd0,8 ) .

    Your /boot/grub/grub.conf file should, probably look like :-
    Code:
    default = 0
    timeout = 10
    splashimage = (hd0,8)/grub/splash.xpm.gz
    title Fedora Core (2.6.11-1.1369_FC4)
    root (hd0,8)
    kernel /vmlinuz-2.6.11-1.1369_FC4 ro root=/dec/hda9
    initrd /initrd-2.6.11-1.1369_FC4.img
    title The wonderful windows
    rootnoverify (hd0,0)
    makeactive
    chainloader +1
    This says that the default operating system will be the first defined (remember grub counts from zero and not one), and that this operating system will be loaded after 10 seconds, unless you use the cursor arrow keys on your keyboard and select the second operating system. Each operating system's definition starts with a "title" line. These (two) title lines are what is presented to you when grub displays its menu, at boot time. the 'splashimage = (hd0,/grub/splash.xpm.gz' lines says that a pretty background picture (proably just something with the words Fedora on it) will be displayed.

    So, either get yourself to a grub> prompt or to a Linux command line prompt for the root user (also known as the superuser. "root" in this sense has NOTHING to do with the root of your filesystem. Silly re-use of the same name), then re-install grub (on either the mbr or the begining of a linux partition (don't put it on the windows partition, as you'll loose your data)) so that it knows that the stage1.5 and stage2 files are on your /boot/ partition (called either (hd0,8 ) or /dev/hda9 ) and you'll be fine.

    have fun

    Nerderello
    ps. you may have noted that there is an extra space after the 8 when I write (hd0,8 ). I have had to do this as otherwise it gets turned into a smilie - like so (hd0, .

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •