Find the answer to your Linux question:
Results 1 to 3 of 3
I've been having some serious problems with Linux ever since I decided to install it. The problems aren't with the OS itself, but rather with booting. I have two hard ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Location
    Pittsburgh, PA
    Posts
    1

    Installation Problems Linux, Windows XP, Grub


    I've been having some serious problems with Linux ever since I decided to install it. The problems aren't with the OS itself, but rather with booting. I have two hard drives on my system, the first I chose to keep with Windows XP at least until I learned enough about Linux and could transfer my important files over, and a second, smaller hard drive which I had intended to use for Linux. My roommate gave me these disks, which came from the university's software distribution center, for RedHat Enterprise WS v 4.

    The first time I installed Linux I chose to have Grub, which I understood to be the utility which would allow me to select which operating system to boot, installed on the first partition of the second hard drive, where my Linux install would be. No problems with the install, but when I rebooted the machine I could never get Grub to come up so that I could select which OS to boot. So, I figured I would reinstall Linux but this time move Grub so that it would overwrite the MBR, believing that whoever designed Grub knew enough that if I ran into problems that a solution would be easy enough to find.

    However, now when I boot up my machine I am receiving a SMART error on my primary hard drive, telling me that there is imminent hard drive failure and that I should back up my data as soon as possible. Grub would attempt to boot Windows XP but wouldn't get very far before I received errors on rootnoverify and chainloader. I can get into Grub though, working around the SMART error but placing a bootable disk into one of the drives but not selecting to boot from the CD/DVD. That would bring up the Grub boot menu where I could now also select to boot my RedHat Linux. Currently this is the only option that is working for me.

    My roommate decided to change Linux distros today on his machine and downloaded the SuSe install and burned it to DVD. He was extolling the benefits of SuSe, which included better support for dual booting. I've now spent several hours attempting to get this install for SuSe working. He had already used this same DVD and now has SuSe running on his machine, but I'm continuing to run into problems. Everything seems to be going fine until I get to the screen where it asks me what type of installation I would like, with the options of New Install or Update. I chose New Install and clicked on the Next button. I then sat there for quite a long time, got up and made something to eat, watched a little TV, came back to find it still sitting on the same screen. I rebooted my machine, went back in, tried it again and got the same result. I tried yet again, selecting this time the option for install without the ACPI (I think those were the initials, no idea what they mean), still got to the same point with the same results. I then tried again, this time choosing the safe mode installation option. I pressed the Esc key to watch its progress and it only got 68% of the way through the initial system check before it too hung, not even getting me as far as the other two options. I know the disk is good, my friend used it on his machine and everything seems to be running smoothly for him.

    Are these problems being caused from my selection of having Grub overwrite the MBR? Any idea what I'm supposed to try next? I tried using the original install disks for Windows XP to try to get into the fixmbr, or even the System Restore, but it won't load the install program all the way now either. When I boot my machine I do get a message indicating, from the bootable CD/DVD I have in the drive I assume, "Boot from ATAPI CD-ROM: No emulation."

    As you can probably tell I enjoy a challenge but at this point feel like I'm beating my head up against a brick wall, not getting anywhere for a couple weeks now. Is there anybody out there who might be able to help me with these problems?

    Thanks!

    Ray

  2. #2
    Just Joined!
    Join Date
    Aug 2005
    Location
    Berkshire, UK
    Posts
    80
    If you had got the message
    Boot from ATAPI CD-ROM: No emulation
    when you first tried the install, I would have suggested that your BIOS didn't support the booting style from CD which was needed (happened in the earlier days of CD booting).

    Given the stage you got to, and the SMART message(s) for the HDD, I suggest that you have a serious (possibly) hardware problem.

    I would first clean out the machine, and reseat all the boards and the memory (taking due care and precautions against static discharge), and then try again. If you still get the messages, then it may be new PC time.

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    11
    that S.M.A.R.T. message means your hard drive is about to quit on you. Boot into Linux and then save the data on your Windows hard drive then zero-fill it. This will erase everything including your MBR which might be bad if you want to keep the original linux OS. If this does not work or fix the drive, you'll need to replace it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •