Find the answer to your Linux question:
Results 1 to 6 of 6
I am brand new to Linux and trying to install and use FC4 in a dual boot environment with Windows 2003 Enterprise Edition. Initially performed installation of Windows 2003 with ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2005
    Posts
    2

    GRUB nevers starts, what's the solution?


    I am brand new to Linux and trying to install and use FC4 in a dual boot environment with Windows 2003 Enterprise Edition.

    Initially performed installation of Windows 2003 with no issues.

    This installation was on a drive dedicated to W2k3.

    Followed by successful?? installation of FC4 on a different drive.

    After rebooting I can not access the FC4 installation...Windows 2003 keeps re-starting as if it was the only OS installed on the system.

    My impression is that the issue resides around GRUB and MBR previously laid down by the Windows 2003 installation.

    Multiple re-installations of FC4 report success, however, GRUB never starts and therefore, am not able to either start FC4 by default or select it as an alternative operating system.

    Any help in resolving this issue would be appreciated.

    Please, keep in mind that I am brand new to Linux.

    Thanks

  2. #2
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    I suspect that what is happening is that FDC4 is putting grub on the master boot record (mbr) of the second hard disk (the one that Linux is being installed on), but that you are still booting from the first hard disk (the one with windoze on it).

    Thing is, every hard disk has a mbr at its very begining. So, I suspect that on the windows hard disk's mbr you have a windows loader (as supplied by Uncle Bill) and on the linux hard disk you have grub (as supplied by fedora Core Linux).

    Solution:

    In the BIOS you can change the boot device order. This allows you to say which hard disk (and therefore which mbr) should be looked at first for an operating system (or bootloader - grub). So, when you power on, get into your BIOS (normally done by pressing either Del or F2 right at the beginning of the power up process - while it is still doing the POST checks). Then the next step depends upon the BIOS you have. On my PC, I get a blue screen (not the windows blue screen of death!) and then have to use the cursor arrow keys to go down to advanced menu option, press enter, and then go down to the bootdevice (shows as hd:0 or some such, but on other , older, BIOSs I've seen them referred to as DOS drive letters - C: D: etc). I change this (press enter to get a sub-menu) to the hard disk I want (probably hd:1 for the second hard disk), and then use the Esc key to rise up menu levels to the first screen and then naviagte across to the Save and Exit option and there you have it.

    Note: You can specify more than one boot device. So you can say to the BIOS, first look at my floppy disk drive, if nothing found, then check my CDROM/DVD drive, if nothing found then, check hard disk number such and such (normally only three options). Or you could say, look at hard disk 2 then hard disk 1. You get the idea.

    Don't worry about fiddling around in the BIOS, if you get lost, you can always Escape out of it and Exit Without saving.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  3. #3
    Just Joined!
    Join Date
    Dec 2005
    Posts
    2

    Thank you and no access to W2k3 surfaced

    Nerderello,

    Thank you very much for your help...you gave me sufficient education to overcome booting to GRUB... many hours have been spent since last Wednesday trying to understand what was the issue when approximately 4 or 5 different and reportedly successful re-installs did not shed enough light to resolve the issue.

    Now I am facing another issue that seems more difficult because I suspect it requires knowledge of syntax (commands) I do not know; in other words, GRUB is not configured is proper commands to allow access to W2k3.

    Here's the scenario:

    From the GNU GRUB ver. 0.95 boot menu when I select 'Other' to boot W2k3 it yields the below results:

    Booting 'Other'
    rootnoverify (hd1,0)
    chainloader +1
    - [the dash means a blinking underscore]

    Would you or someone else take time to share the solution with me?

    Perhaps, as a minimum, you need to know the following:
    • the system is built with two drives
    • drive hda is for Windows 2003 (tons of space)
    • drive hdb is for Fedora Core 4 (tons of space)
    • Windows 2003 was installed first (works perfectly fine, for now)
    • No issues booting to W2k3 until acces to GRUB was achieved by implementing solution suggested by Nerderello together with a re-install and adjustments to configuration (once you know what should be done!)
    • It seems GRUB needs proper redirection commands to start W2k3 from MBR in hda as opposed to hdb
    • In other words, FC4 is fully implemented in hdb including GRUB
    • and W2k3 is fully implemented in hda
    • I guess the issue is how to tell GRUB to boot W2k3 from hda?

    Many thanks for the help,
    Abe

    PS. Today was my first time to taste Linux...first impression is that it is sweet!! I just need to get beyond these booting issues and focus on learning what seems to be an industrial strength caliber operating system!!!

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined! Nosher's Avatar
    Join Date
    Nov 2005
    Location
    UK
    Posts
    20
    Another option, if you are able to boot to Windows OK, is to use it's bootloader. This will involve downloading a utility called Bootpart from:

    http://www.winimage.com/bootpart.htm

    When installing FC4 you need to specifiy the bootloader location as the root partition rather than the MBR of your second drive.

    Boot into Windows and create a folder on you C: drive called Bootpart and unzip the utility into this folder.

    Open a DOS window and enter the following bootpart command:

    bootpart 1 bootsect.lnx FC4 Linux

    The "1" in the command assumes that Windows is on drive "0" and FC4 on drive "1"

    Now type:

    bootpart list

    This displays all entries in a file called boot.ini and you should see an entry for Windows and another for Linux.

    Now reboot the PC and you should now have a menu containing you two boot options.

    If you specified the location of FC4's bootloader as the MBR of you second drive I'm not sure if you can move it - perhaps someone else could offer advice on that one?

    I have an old PC with exactly this setup - Windows on the first drive and Red Hat 8.0 on the second and this method seemed to work a treat.

    Enjoy!

    Regards

    Nosher

  6. #5
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    first, Abaezjob, I've covered doing this sort of thing in the tutorial what I wrote on this very subject in this site(see :- http://www.linuxforums.org/forum/t93...d-edition.html ).

    From what you say, the Windows is on the first hard disk (called /dev/hda by Linux) and in the first (perhaps only) partition (I suspect) . So the correct name for this partition, in Linux, is "/dev/hda1".

    However, we are not dealing with Linux, but with grub. Grub has to be able to deal with any operating system, so it uses its own, independent of any operating system, naming convention.

    The grub naming convention is :-

    1) Numbers are counted from zero (0) not from one (1).
    2) Hard disks are numbered (from 0) not lettered.
    3) Partitions are numbered (from 0).

    So, the first hard disk drive is called hd0 (that's a zero and not a capital O). The first partition on that hard disk (the first hard disk) is called, in all its glory, hd0,0 . Grub puts brackets around this, so you end up with (hd0,0) .


    As you can see from your readout, your grub has been configured to look at the first partition on the second hard disk drive (where Linux lives). The reason that Linux doesn't load with this piece of code, is that it needs a different way of being called.

    So, to solve your problem:-
    1) read (at least skim through) the tutorial (it took me hours to write)
    2) edit your /boot/grub/grub.conf file (if you are unsure of how to do this. Open a terminal window. Make yourself root user ( enter "su -" followed by the root users password ), the last charcter of the command prompt will change from a $ to a #. Start up an editor, either by entering "gedit" if in Gnome or "kedit" if in KDE. Now things should start to feel familiar. Open up the file called /boot/grub/grub.conf )
    3. Use the sample grub.conf from the tutorial to guide you. It's about two thirds of the way down. Don't worry about the map statements in the sample, you don't need them.
    4. The only lines (plural) you need to change are rootnoverify (hd1,0) (you should, by now, know what number to change and what to change it to) and the title line (give it a meaningful name. After all Uncle Bill works very hard to make people aware of the glories of Windows. You might like to try something like Uncle Bills pride and joy or simply Windows).
    5) Save the file. Exit the editor. Close the terminal window. Reboot.

    enjoy

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  7. #6
    Linux Enthusiast Weedman's Avatar
    Join Date
    May 2005
    Location
    Tasmania, Australia
    Posts
    640
    try this:
    Code:
    root (hd0,0)
    map (hd0) (hd1)
    map (hd1) (hd0)
    chainloader +1
    boot
    if putting boot at the end doesn't work, try without it.

    just my 2 cents

    weed
    "Time has more than one meaning, and is more than one dimension" - /.unknown
    --Registered Linux user #396583--

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •