Find the answer to your Linux question:
Results 1 to 8 of 8
Well.. i think i did. I was using Partition Magic to partition my HDD, and when i split my 130gb partition to make a 100gb for the stuff already on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2006
    Posts
    17

    Unhappy I am an Idiot: I renaimed C:


    Well.. i think i did.

    I was using Partition Magic to partition my HDD, and when i split my 130gb partition to make a 100gb for the stuff already on that partition and a 30gb FAT for my music, and Partition Magic named that 30gb C:

    so, i thought that XP wont launch correctly if two C: drives pop up, so i relettered that drive. and i looked at the drive with windows on it, and it didn't have a letter :o so i gave it C:

    then i applied the setting...
    when i came back the BIOS says that it could not find an OS :O

    So, how can i get Windows to boot again?

    I was just on a Slax live CD to see if the the drives, and its partitioned, and my data is all there... now i just need to get win to boot....

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Boot from the windows XP cd, goto the recovery console and enter this command:
    Code:
    fixmbr
    That should get the windows bootloader installed for you. Note, doing this will erase whatever previous bootloader you had e.g. grub or lilo.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Jan 2006
    Posts
    17
    Quote Originally Posted by AlexK
    Boot from the windows XP cd, goto the recovery console and enter this command:
    Code:
    fixmbr
    That should get the windows bootloader installed for you. Note, doing this will erase whatever previous bootloader you had e.g. grub or lilo.

    :-/

    i've been going into the XP recovery mode for the past day -_-

    I've found out that the drive with Win on it is now called G: (formerly my C. I think the recovery mode thinks my OS is on partition H because everytime i type in "fixmbr" or "fixboot" it automatically goes to H:.
    So, I type in "fixmbr g:" and restart, and still, no Win goes up.

    i tried "bootcfg" but it always end up saying Error after the place you're supposta type in "/fastdetect"

    :-/ Uhhhh.... does anyone wanna come over and help me? I got cookies
    LOL

    +_+

  4. #4
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    because everytime i type in "fixmbr" or "fixboot" it automatically goes to H:.


    I am not sure what you are trying to say here.
    What happens if you just use "fixmbr" and reboot?
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  5. #5
    Just Joined!
    Join Date
    Jan 2006
    Posts
    17
    ^it gives the error message again.

    what i was trying to say was that when i type in "fixmbr" it asks if i am really sure i wanted to fix the master boot for partition H:
    when i say yes, and reboot, it still says error

    windows is on partition G: now
    so when i type in "fixmbr g:" it asks if i am sure i want to fix the master boot in partition G:
    i say yes,
    and reboot
    and it says error -_-

    DUDE! BUDMAN!
    you live in GR, MI. I live in Wyoming (didn't edit profile yet)
    :o
    can i call you? cuz none of my friends know linux, if they do, they are at Michigan Tech right now. LOL (im so desperate for help)

  6. #6
    Super Moderator Roxoff's Avatar
    Join Date
    Aug 2005
    Location
    Nottingham, England
    Posts
    3,807
    Two suggestions here:

    1. cant you change your bios to select the partition to boot from? I had a bios like this a few years ago, and it auto-selected the partition I booted from as drive C: (I only used this for multiple windows boots - linux was never so easily confused).

    2. there is a setting in boot.ini on the root of the boot drive which tells windows which physical disk and physical partitions it can boot to. Can tweaking this to read something like "partition(7)" for drive "G:" help? Dont forget to take a backup of the file before you start chopping it.
    Linux user #126863 - see http://linuxcounter.net/

  7. #7
    Just Joined!
    Join Date
    Jan 2006
    Posts
    17
    thanks all, i solved my own problem now

    i was tired of the booting and CLI... so early in the morning today (2AM) i chose to "screw it, idc anymore" and install SuSE anyways.

    and u no what? SuSE's bootloader recognized windows

    Hurray!
    another one of my dumb quick decisions that solved a dumber quick decision ^_^

  8. #8
    Just Joined!
    Join Date
    Jan 2006
    Posts
    17

    I lied

    Hahah... guess what? i screwed it up even more :-/ not fix it. -_-

    Windows now is on the bootlist, but when u choose Windows, it launches, and you can see that 4 color window flag boot up screen, but then... it just reboots. so i never get to finish booting up windows. -_-
    i tried pressing F2 to get into the startup menu, but i cant get to there -_-

    And, i realized that i forgot to make a SWAP partition during installation... how can i do it now on SuSE?

    sorry it took me a while to repost this help, cuz my LAN was messed up :-/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •