Find the answer to your Linux question:
Results 1 to 5 of 5
This is on a Compaq Presario 900 laptop, dual-booting Windows XP and Linux. Athlon XP 1900+, 512MB RAM, 40GB HDD, DVD/CD-RW drive. Actually, I currently have Mandrake 9.2 RC1/2 (can't ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Posts
    3

    Can't install Linux on Laptop...


    This is on a Compaq Presario 900 laptop, dual-booting Windows XP and Linux. Athlon XP 1900+, 512MB RAM, 40GB HDD, DVD/CD-RW drive.

    Actually, I currently have Mandrake 9.2 RC1/2 (can't remember) installed on this machine right now dual-booting with Windows XP. Problem is, I had to reinstall Windows XP and that wiped out the Linux boot loader. At a minimum, what I need to be able to do is somehow boot a rescue image, mount the root partition, and reinstall LILO.

    However, I no longer have the Mandrake 9.2 Release Candidate media. Instead, I have tried using the offical release of Mandrake 9.2. It loads the graphical setup without problems, but then it gives me this:

    An error occured
    An erorr occured - no valid devices were found on which to create new filesystems. Please check your hardware for the cause of this problem.

    I've checked the other VTs, and I can see some kernel messages which look like:

    hda: status timeout: status=0xd0 { Busy }
    drive not ready for command
    ide0: reset timed-out, status=0xd0
    end_request: I/O error, cmd 0 dev 03:00 (hda) sector [56]

    I don't know why the Release Candidate of Mandrake 9.2 worked and the official release won't. So, I downloaded Core 1 of Fedora and tried it. To be quite honest, I would rather have Fedora on this laptop than Mandrake--but I have an even bigger roadblock there: it cannot even find the installation media. Here's what it says:

    The Fedora Linux Core 1 CD was not found in any of your CDROM drives.

    I also see similar "end_request: I/O" errors for the CDROM (hdc) on the other VTs for the Fedora installation. Also, I see similar errors for the hard drive (hda), so I'd imagine that I'd run into similar issues there even if it could mount the media.

    I have tried booting both distributions with the "nomce ide=nodma pci=biosirq" kernel arguments--and they have no effect whatsoever. I've even tried adding "hdc=ide-scsi" for the Fedora installation to help recognize the DVD-RW, and it didn't do anything.

    Any ideas?

    Thanks!

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    u dont need to reinstall anything, or even have a GUI.

    put in any mdk cd, now when it first comes up with loading program: enter to continue of f1 for options, press f1, now type rescue.

    From here there is an option of reinstall bootloader which probably will do what u want but ive never tried ir, u could click his and hope it works (my guess is 90% good it will), or u coudl do it my way which is longer but WILL work.

    My way. click on the go to console thing. type the following code

    Code:
    lsparts
    now check for ur / drive (probably the first partition listed as ext2/3)

    Code:
    mkdir /real
    mount /dev/hda1 /real   <------- this assumes hda1 was the / partition
    ls /real
    now check the output of ls looks like ur / partition used to. (should have /root, /etc, /usr, /home etc)
    if it isnt the right drive just umount it and try another 1, onc eu have the correct partition mounted go on to next bit.

    Code:
    chroot /real
    /sbin/lilo
    now u have lilo installed as ur bootloader again. reboot and u should be all good.

  3. #3
    Just Joined!
    Join Date
    Dec 2003
    Posts
    3
    Thanks for the detailed response, Hellmasker.

    I know what you're saying. Only problem is, Linux still can't access my hard drive--it just gives all of those "status timeout" and "drive not ready for command" errors. I get the same results for both Mandrake and Fedora (and Fedora has the added problem of not being able to access my CDROM).

    On a side note, both distros can "kinda" see my hard drive. I can tell in the kernel boot messages that it's seeing a Fujitsu drive as hda. It's also detecting the partitions that are there, and I have been able to run the lspci command when running the rescue console, which properly lists my three Linux partitions. When I try to do something like "fdisk", however, it won't work.

    So what I really need is to be able to somehow get one of these CDs (or even another distro, if I have to) to be able to somehow access my hard drive.

    Thanks

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    One option would be to create a GRUB boot disk (go to my homepage - link at the bottom of the post - and download the GRUB image and rawrite.exe for Winbloze), and use that to boot your Mdk system.

    Since I don't know what partitioning scheme you have used, I cannot give detailed instructions, but here is the general scheme:
    Boot off the floppy, and you should get the "grub>" prompt. First, you need to load the kernel image. If you have a /boot partition on /dev/hda1, the commands would be something like this:
    Code:
    root &#40;hd0,0&#41;
    kernel /vmlinuz-version
    Replace version with the actual version number of your kernel. Tab completion works in GRUB, so you can use that to aid you in finding the version.
    If, instead, you don't have a /boot partition, but only a root partition on, say, /dev/hda3, use this instead:
    Code:
    root &#40;hd0,2&#41;
    kernel /boot/vmlinuz-version
    After that, if Mdk uses an initrd (I can't seem to remember whether or not it does), you need to load that as well. It's basically the same as loading the kernel, just use the "initrd" command instead of the "kernel" command, and use initrd-version (or initrd.img-version or initrd.img.gz-version or whatever scheme Mdk might use) instead of vmlinuz-version.

    Also, the kernel command I gave above is not complete; you also need to pass the partition to mount your root filesystem from. That's easy though. If your root filesystem is on /dev/hda3, just add " root=/dev/hda3" to the end of the "kernel" command, so that the final result is something like this:
    Code:
    kernel /vmlinuz-version root=/dev/hda3
    Then, when everything is done, use the command "boot" to actually boot the kernel.

  5. #5
    Just Joined!
    Join Date
    Dec 2003
    Posts
    3
    Thanks for the reply Dolda2000.

    Unfortunately, that method wouldn't work for me either since this laptop doesn't have a floppy drive...

    I did, however, manage to get Fedora installed (and the same should work for Mandrake as well, FWIW). The magic kernel argument I needed was:

    pci=off

    I know I used some of the other "commonly used" arguments as well--nomce for sure. I did not, however, need use ide=nodma, and if I figure that's a good thing because DMA should ideally be enabled for best performance.

    After I got the kernel arguments right, Fedora installed without any hitches. There are only two other things that need to be done after Fedora is installed:

    1. Append nousb to the list of kernel parameters that GRUB passes at boot time (press "a" when you see GRUB). I didn't need this argument when I installed Fedora, but it is neccessary after it's installed or else the system will hang when it tries to bring up the USB subsystem. Yes, that means no USB support (at least out of the box--haven't tested what a custom kernel might be able to do).

    2. Disable kudzu. To do that, I needed to boot the Fedora recovery console (using the same kernel arguments when used to install), mount and chroot into the system root directory, and then run "ntsysv --level=5" to disable kudzu from running at boot time. If you don't disable kudzu, your system will hang.

    After taking the previous two steps, I had Fedora Core 1 running great on my machine. The video is perfect, sound is there, network works, the touchpad works, and the DVD/CD-RW drive all work great. I haven't tested the PCMCIA capabilities (since the only PCMCIA card I have is a Netgear wireless card and isn't compatible with Linux), and I don't know what the deal is with the USB.

    Thanks for the help--hopefully this post will help others with the same problem.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •