Find the answer to your Linux question:
Results 1 to 3 of 3
ok i've got 3 probs, lets see if we can fix one or the other, maybe all 3! Prob 1: i have 2 cdroms [burner and dvd] below is the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Dec 2003
    Posts
    19

    Probs with CDRom and Sound


    ok i've got 3 probs, lets see if we can fix one or the other, maybe all 3!

    Prob 1: i have 2 cdroms [burner and dvd] below is the burner i believe but i cant mount the second one, and i dont think the bruner is recognized as a burner

    Prob 2: my sound dosent work, the volume is up in mmx (lol) and the cables are correct. i dont know how to deal with sound cards.

    Prob 3: my burner software, k3b wants me to enable ide-scsi (SCSI emulation) for all devices. do i need to do this? how do i do this?


    fstab looks like this :
    /dev/hda swap swap defaults 0 0
    /dev/hda2 / ext2 defaults 1 1
    /dev/hdb1 /fat-d vfat defaults 1 0
    /dev/cdrom /mnt/cdrom iso9660 noauto,owner,ro 0 0
    /dev/fd0 /mnt/floppy auto noauto,owner 0 0
    devpts /dev/pts devpts gid=5,mode=620 0 0
    proc /proc proc defaults 0 0

    Thankyou

  2. #2
    Just Joined!
    Join Date
    Dec 2003
    Posts
    19

    new adition

    i realized that:
    :: my burner is /dev/hcc
    :: my dvd is /dev/hdd

    but i still dont know what to do whit these to make the drives work.

  3. #3
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    because of some "problems" with linux burnrnign programs u need to enable scsi emulation on any cd/dvd writers else they are read only. to do this: (i assume u use lilo as a bootloader) as root edit the /etc/lilo.conf file so that the line labelled "append" in the kernel u want to use has "hdc=ide-scsi hdd=ide-scsi" in it. jsut add these 2 commands inside the "".

    this will make it so /dev/scd0 and /dev/scd1 and ur 2 drives. which is which depends on what order the 2 appear in the lilo.conf file. to find out run "eject /dev/scd0" and see which drive opens.

    now we will set up the mount points. Lets first remove the cdrom point. "umount /mnt/cdrom" "rmdir /mnt/cdrom" Now we will make 2 mount point called cdr and dvd. "mkdir /mnt/cdr" "mkdir /mnt/dvd"

    Now edit /etc/fstab by changing the line reading "/dev/cdrom mnt/cdrom..." to "/dev/scd0 /mnt/dvd iso9660 ....." (assuming scd0 is ur dvd drive) and then copy the line right below it, but change it to scd1 and cdr.

    now when u reboot i will have set up scsi emulation on the 2 drives and have them set up to mount. (by typing "mount /mnt/dvd", etc)

    Now for the sound:

    first check that ur card is detected. lspci shoudl tell u.

    now open up /etc/modules.conf as roto and look for the lines

    Code:
    above snd-via82xx snd-pcm-oss
    alias char-major-116 snd
    alias snd-card-0 snd-via82xx
    alias sound-slot-0 snd-card-0
    U will prob have a difefrent sound card and maybe some slight differences but as logn as there is something.

    type aumix at a console and check if anythign is muted and that decent volumes (70%) are set up.

    If u still havent fixed it reply back. with details or ur card, and if u use KDE, gnome etc, and what it does/does not work with

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •