Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
Hi all Just installed Slackware 8.1 Everything works fine, except sound When I log in as root, the sound works However, when I login as any other user, it complains ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Oct 2002
    Location
    Norway
    Posts
    17

    mixer and non-root access


    Hi all

    Just installed Slackware 8.1
    Everything works fine, except sound

    When I log in as root, the sound works

    However, when I login as any other user, it complains I dont have permissions to access /dev/mixer

    How do I fix this??

    Thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Open the file /etc/security/console.perms and see if /dev/mixer is listed there.

  3. #3
    Just Joined!
    Join Date
    Oct 2002
    Location
    Norway
    Posts
    17
    Thanks for the quick reply!

    /etc/security does not exist on my system

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Does slackware use RPMs? If so, run "rpm -ql pam | grep console.perms" and see what it says. Also, look in /etc/pam.d/gdm and see if pam_console.so is anywhere in there.

  6. #5
    Just Joined!
    Join Date
    Oct 2002
    Location
    Norway
    Posts
    17
    there is the rpm command, but packages are installed from source, not with the rpm command

    /etc/pam.d/ directory does not exist

    I cant find anything on slack site that will point me to where the permissions are held.. Im stuck

  7. #6
    Just Joined!
    Join Date
    Oct 2002
    Location
    Norway
    Posts
    17
    also did a find for pam_console.so
    no result

  8. #7
    Just Joined!
    Join Date
    Oct 2002
    Location
    Norway
    Posts
    17
    Ok, I fixed it
    For those who want to know...

    I opened nautilus and chmoded:
    /dev/dsp
    /dev/mixer
    to 0666 to give everyone access to the mixer and the sound device

    Also chmoded:
    /mnt/cdrom (s link to /dev/cdrom for ease)
    /dev/hdc (cdrom device)
    /dev/cdrom (s link to /dev/hdc)
    all to 0666, to enable any user to access the CD ROM to play Audio CD's

    Had to change the fstab cdrom line too
    inserted 'user' to enable accecss to all

  9. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Are you sure that you installed PAM? Without PAM, it's certain not to work, unless you write a perms script yourself or something, that is.
    If you're the only user of the computer, you could of course chown /dev/mixer and the other related files (/dev/dsp and so on) to your own user, or even better, add yourself to the adm group and chown the files to root:adm.

  10. #9
    Linux Enthusiast
    Join Date
    Jun 2002
    Location
    San Antonio
    Posts
    621
    Dolda: hmm. . . I have never done any checking on console.perms. I always jut chown/chmod the sound devices and add people to default groups. Is the console.so file a better way to do this? Maybe I need to learn more about PAM, I am lacking in the authentication process knowledge.
    I respectfully decline the invitation to join your delusion.

  11. #10
    Just Joined!
    Join Date
    Oct 2002
    Location
    Norway
    Posts
    17
    If you say that PAM must be installed, then it is, cos this installation I installed EVERYTHING off the Slack 8.1 CD, and ALL from the slack-current tree

    But I though of doing the chown thing before PAM, cos I havnt a clue about PAM authentication.

    And it works, the machine isnt connected to the internet, so Im not worried about any security issues this brings up

    If it works, why mess with it?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •