Find the answer to your Linux question:
Results 1 to 4 of 4
Greetings I just bought a new computer. But I'm having trouble installing Linux. Here are the specs: Motherboard ASUS P5V800-MX (INTEL Socket 775 > VIA P4M800) Intel Pentium 4 3.0GHz ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3

    Linux Installation on SATA HD


    Greetings

    I just bought a new computer.
    But I'm having trouble installing Linux.

    Here are the specs:
    Motherboard ASUS P5V800-MX (INTEL Socket 775 > VIA P4M800)
    Intel Pentium 4 3.0GHz
    1 GB RAM
    160 GB 7200 rpm SATA
    DVDRW Dual Layer
    (no floppy drive, which unfortunetely is very important in installation issues)

    He came with windows XP installed. I really need to install some linux distro on it, so
    I started by resizing windows NTFS partition to make unallocable space for linux.
    (I don't know if this is enought, because I've heard sometimes that it's necessary to create
    partitions for swap, boot, etc - I just did the resize because I thought Fedora installation
    CDs would take care of the rest)

    First Try:
    Then I boot from Fedora 3 first installation CD.
    However, I don't even get to that stage. When the system boots from the Fedora CD,
    no hard drive is detected. He gives me the chance to load device drivers, but I don't
    have any SATA hard drive installation disks, and even if I had I don't have the floppy
    driver.

    Second Try:
    I then try a more recent distro, SUSE 10 evaluation version. First problem was the
    message "Cool PC, running 32 bit software on 64-bit computer" and it goes to "manual mode".
    (my pc isn't 64 bits).
    Then I still have a chance to look for hard disks, but none is detected.

    Bios Settings:
    The Maxtor SATA disk is detected as THIRD IDE MASTER. And the DVDRW as SECONDARY IDE MASTER.
    I don't know if this is good for linux.

    First Try to Fix:
    I read that a similar problem could be fixed if I change BIOS settings of SATA disk to
    Compatible or Legacy Mode. However, in BIOS, the only reference to SATA that I find
    (other that displaying it in THIRD IDE MASTER) is under Chipset->SouthBridge->SATA
    with Disabled/SATA/RAID as options. And none of them work.

    Second Try to Fix:
    I read an how-to consisting of several steps like: installing same distro on an IDE driver,
    downloading kernel source files, Maxtor SATA drivers for Linux, Compiling the Kernel,
    Saving to floopy, Boot from CD, and go from there (something like that).
    However I don't have the hardware resources (another disk or computer, nor floppy).
    Furthermore, as you can see, with my linux "know how" I would hardly be able to perform
    all those steps.

    I really need help. I'm going dispair and frustrated. One of the main reasons I bought
    the computer was to be able to dual boot windows and linux and start learning something.

    Thanks Beforehand,
    Pedro Vaz

  2. #2
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Do you have your drive set up in any type of RAID configuration? I've successfully installed SuSE 10 and FC4 (though I haven't tried 3) on a SATA drive hooked up as a regular drive.

    Also, what type of Pentium 4 do you have specifically? Some Pentium 4's are actually 64-bit (they use EM64T technology), so that might be why SuSE was warning you. Either way it should have let you install the 32-bit version anyway.
    Registered Linux user #270181
    TechieMoe's Tech Rants

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    3
    Hi,
    Thanks
    The 64-bit issue doesn't worrie me because now I've tried knoppix4.0.2, ubunto5.10,
    suse 10 and fedora 3, and only SUSE 10 mention that 32-bit/64-bit problem.
    The others, all detect dvd-drive (except SUSE 10 - which is odd), but don't detect hd.

    The sata drive being detected by bios as "Third IDE master" is ok for linux installation?

    Thanks beforehand,
    Pedro

  4. #4
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by qqcoisa123
    The sata drive being detected by bios as "Third IDE master" is ok for linux installation?
    How do you have your drives hooked up? You might consider unplugging your other drives and making your SATA drive the primary master.
    Registered Linux user #270181
    TechieMoe's Tech Rants

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •