Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
Hi guys new to Linux here...I have 2 HDs intalled on my pc. Specs are: AMD 64-bit 3500+ Corsair XMS 2GB XFX Geforce 7800GT Creative Audigy ZS WD 250 SATA ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    7

    Boot question / problem...


    Hi guys new to Linux here...I have 2 HDs intalled on my pc.
    Specs are:

    AMD 64-bit 3500+
    Corsair XMS 2GB
    XFX Geforce 7800GT
    Creative Audigy ZS
    WD 250 SATA II
    Maxtor 30GB IDE

    I currently have Windows XP Home Edition installed on WD hd and have other files in it. I just recently installed Linux on the 30GB IDE drive. My problem is how come I dont get the option to dual boot ? It just goes right to windows everytime I restart. How can I set this up so I can choose which OS to boot to?

  2. #2
    Just Joined!
    Join Date
    Jan 2006
    Posts
    8

    the answer is

    you didn't install bootloader (grub or lilo) to the MBR . Re-install linux and do it right.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    7
    I did, On my first install I tried LILO and it still the same thing...I just did a second fresh installation and used GRUB this time and still the same thing..

  4. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    7
    ok just did some experiment and confused with outcomes...

    first, I unplugged the hard drive that contained Windows XP (WD SATAII) and Redhat Linux 9 loaded up.

    second, I plugged it back and then linux automatically loaded up without asking me which OS i wanted to boot to. ( System detected the SATAII HD btw)

    third, I unplugged the drive that has linux (Maxtor IDE Hard Drive) and it booted windows normally as I assumed.

    fourth, I plugged all the drives back and got windows to boot up without asking me which OS to boot. (System detected Maxtor IDE Hard Drive)

    Does it matter if the SATA II that windows is on is running NTFS file system, even though I have linux on a completely separate physical drive thats running its own file system???

  5. #5
    Just Joined!
    Join Date
    Feb 2006
    Posts
    7
    Anyone got a hunch? such a weird problem.

  6. #6
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,132
    Sounds like you need to install lilo on the other hard drive. Alternatively you can use smart boot manager or your bios to choose which disk to boot from.

  7. #7
    Linux Engineer spencerf's Avatar
    Join Date
    Jan 2005
    Location
    Syracuse, NY
    Posts
    1,144
    In your bios you will have an option to choose the boot order. Choose the IDE drive to be the first one.

    Then in grub add this:
    title=Windows
    rootnoverify (hd1,0)
    makeactive
    chainloader +1
    All right, brain. You don't like me and I don't like you, but let's just do this and I can get back to killing you with beer. All New Users Read This!!! If you have a grub problem please look at GRUB MANUAL

  8. #8
    Just Joined!
    Join Date
    Feb 2006
    Posts
    7
    Thanx guys, I just went to the bios and changed the boot order then re-installed linux. Only one problem now, I cant find drivers for my mobo built in NIC card...grr

  9. #9
    Linux Guru budman7's Avatar
    Join Date
    Oct 2004
    Location
    Knee deep in Grand Rapids, Michigan
    Posts
    3,242
    What nic do you have?
    Which version of Linux are you using.
    How to know if you are a geek.
    when you respond to "get a life!" with "what's the URL?"
    - Birger

    New users read The FAQ

  10. #10
    Just Joined!
    Join Date
    Feb 2006
    Posts
    7
    Im using Redhat Linux 9 and the built in NIC is Nvidia Nforce Networking Controller in my Abit KN8 Sli Mobo. And Also I cant find a linux driver for my XFX Geforce 7800GT PCIe...I tried using the Nvidia Geforce option but no luck.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •