Find the answer to your Linux question:
Results 1 to 9 of 9
Hello, I am pretty much a newbie to Linux. We are actually trying to set up a cluster and had installed Rocks (which is built upon RedHat 7), this used ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    2

    Question Grub error 22


    Hello,

    I am pretty much a newbie to Linux. We are actually trying to set up a cluster and had installed Rocks (which is built upon RedHat 7), this used CentOS. Now when I was trying to reinstall the same OS on with extra functionalities on the previous OS, it did fine on the first computer (the frontend).

    But when I tried to do it on my second node, it gave some error... I had to remove my CD midway and now when I boot the computer from harddisk, I get an error msg like:

    Grub loading stage 1.5
    Grub loading , please wait
    Error 22

    After this, i get no prompt or nothing whatsoever.. i cant even type a single character.. wht should I do? install Windows or Linux over it again? Is that the only option??

    Please reply .. I have been stuck up here since long now
    Any help would be much appreciated.

    Thanks and Regards,
    Priyanka.

  2. #2
    Linux Newbie exploder's Avatar
    Join Date
    Jun 2005
    Location
    127.0.0.1
    Posts
    164
    Run the Windows XP CD and go for 'recovery console' and at the prompt type
    'fixmbr' you can try 'fixboot' as well.

    Let me know if it worked or else you can run Knoppix Live cd and back up your windows data and you can play around with it to get back the GRUB menu by typing "grub" at the console after you get the Knoppix desktop.

    With Live o/s it will boot from the CD and it wont harm your pc hard drive. Then you can mount your hard drive and back up your data.
    Registered Linux User#394486

  3. #3
    Just Joined!
    Join Date
    Mar 2006
    Posts
    1

    My low-tech solution

    I had the same problem with Win2k3/Ubuntu when I added a Maxtor 250GB HDD. The latter seems to have problems with win2k3, sometimes repartitioning (Acronis PartitionExpert Server Edition) makes the new partition disappear. And sometimes, after reboot, I get the same error.

    I found the less painful solution for me is installing a new Ubuntu (on a 5GB partition I keep for this in the first drive). I choose the "server" installation option (faster and less space required). This refreshes the boot loader and lets me access both win2k3 & previous linux installation.

  4. #4
    Just Joined! il_ciavo's Avatar
    Join Date
    May 2006
    Posts
    3

    Problem with Partitioning

    I'm having a similar problem. I wanted to increase me Suse root Partition. So I decided to remove other linux Partition (/Data1) with Yast. Then, during the reboot apears: Grub Loading... Error 22.
    So please someone could help me on:
    -How to expand the linux root partition
    -How to recover the Grub
    Thanx

  5. #5
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    Grub Stage 1.5 Error 22

    I am encountering a Grub 1.5 error upon boot.

    I am using a 2nd hdd to load Ubuntu for Linux. This was previously a WinXP drive that I deleted and reformatted before attempting to install Ubuntu.

    First I got Error 17.

    Then I restarted from the live cd and reloaded again.

    Now I get error 22

    This is separate from my Win XP drive. I am not using a "dual boot" system. I am changing the boot drive in the bios to start Linux.

    Any ideas on what is wrong?

    -Steve

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    problem is in grub configuration. SWAP harddisks. plug-in Ubuntu harddisk as Primary Master.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Mar 2007
    Posts
    1

    GRUB 22 message

    I am getting the same . At start up if my external harddrive is on when I boot. I do not get it at anyother time.
    If I turn on the external drive after start up I have no problems and the drive is fully accessible.
    Do not understand the reason why but it is the only time i see it.
    Can external devices trigger this message if not recognized at startup?????

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    GRUB is installed in MBR of internal Harddisk but its configuration Files are stored in External harddisk. if you turn off External Harddisk at start up, GRUB couldn't find its conf files and throws errors.
    if your Machine's BIOS supports booting up from External Harddisk, remove GRUB from Internal and install it in External.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Apr 2007
    Posts
    1
    I just installed feisty fawn ubuntu, and dual booted with win xp.

    I got grub error 18 - then reinstalled, then got grub error 17 - reinstalled, then got grub error 22

    I am dual booting with a previous install of xp on one HD, and I added a second ide HD as slave that I installed ubuntu onto.

    error 18: my boot partition was too large...I got this error because I did the guided install.

    error 17: I have no idea?

    error 22: I set the partitions on hdb as follows
    swap
    /boot 2000 mb
    / entire disk 78000 mb

    then when I restarted I got error 22, went into the bios, and set hdb as the primary disk. the restarted and grub loader allowed me to run both installs.

    a) maxtor: ubuntu
    b) samsung: xp

    before it was swapped

    After 3 installs I thought my xp was toast...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •