Find the answer to your Linux question:
Results 1 to 7 of 7
I have a 60GB harddrive in my laptop. I tried to install Mandrake in a seperate partition to dual boot. I was never able to get the mandrake to work ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6

    L99 Help


    I have a 60GB harddrive in my laptop. I tried to install Mandrake in a seperate partition to dual boot. I was never able to get the mandrake to work (i'm thinking its my graphics card), so I decided to get rid of it and use the drive for storage. I went ahead and simply deleted the three logical partitions, and reformatted this free space into one new drive (yes, i know now that this was not the best course of action). It used to be when I booted up that a blue box would pop-up, where I could pick from linux, safe something, and windows (I believe). Now when I boot I get a black screen with something along the lines of "L99 99 99 99 99" and so on. I have the XP discs (OEM discs that I bought and installed). The harddrive has a main windows partition, the linux partitions (now a one storage partition), a primary storage partition (for a total of two storage partitions), and a FAT32 for swapping from linux.

    I have looked into using FIXMBR from the recovery section of the XP disc, but it says that "Caution. This computer appears to have a non-standard or invalid master boot record. FIXMBR may damage your partition if you proceed. This could cause all the patitions on the current hard drisk to become inaccessible. If you are not having problems accessing your drive, do not continue. Are you sure you want to write a new MBR?" Needless to say I don't want to lose my other partitions...

    Ideas? Help? Thanks to all. And don't worry, I will try Linux again.... just not with the laptop.

  2. #2
    Linux Guru AlexK's Avatar
    Join Date
    Feb 2005
    Location
    Earth
    Posts
    3,379
    Do Not post multiple queries regarding the same problem on these forums. All your other threads have been deleted.

    If you are scared of losing the windows partition, download a livecd such as Knoppix and backup whatever data you have.

    Otherwise fixmbr should do the trick. Or a more drastic way would be a Windows reinstall. The reason why the "non-standard mbr" error comes up is because Windows's doesn't recognize lilo or grub and thinks that the MBR might be corrupted.
    Life is complex, it has a real part and an imaginary part.

  3. #3
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6

    Sorry

    Sorry about the multi-posting, I just was not sure which section would be visited by the people who knew the answer, for I had spent many hours looking through forums, and never was able to find this specific style of problem. Thanks for the help though.

  4. #4
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6

    Not Working

    I just tried the FIXMBR command and when I reboot, I still get the "L99 99 99" screen. Any other ideas?

  5. #5
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6
    actually, i did "fixmbr /device0/harddrive0/partition1" which is the partition with windows installed. this did nothing.

    then i did simply "fixmbr" which supposedly did it on "/device0/harddrive0/partition0". now i get the message "invalid partition table"

  6. #6
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6

    also...

    if it makes any difference, when I did the "map" command from the recovery console, it gives me my drives, but has changed some drive letters (i never looked at it before from recovery console, but i know what i had setup before). My harddisks used to be C,E,F,G with my DVD-drive as D: and a virtual drive at H. Now my harddisks are C,D,E,F, with the DVD at G, and the virtual at H (or there about---the harddisks certainly have been relettered). I don't know if this is relevant, but if it is, I don't know how to change the letters back to normal without running windows. I also ran a Knoppix Live CD and it won't let me mount the first partition with windows. The other partitions are fine. Furthermore, running CHKDSK from the recovery console says that there is some problem.

  7. #7
    Just Joined!
    Join Date
    Feb 2006
    Posts
    6
    from another forum where I had the same question, a solution that worked for me....
    [quote name='mark2' post='182867' date='Feb 26 2006, 20:41']
    I found the same problem at one point after removing a linux bootloader, however I then ran fixboot before running fixmbr and the problem was cured
    [/quote]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •