Find the answer to your Linux question:
Results 1 to 7 of 7
Hi, I'm pretty new to linux and just got my new router-modem for my ADSL connection. The modem is an ECI modem, and I connect my computer to it using ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Posts
    6

    connecting with ADSL (ECI modem) that needs authentication


    Hi,

    I'm pretty new to linux and just got my new router-modem for my ADSL connection. The modem is an ECI modem, and I connect my computer to it using my NIC.
    To access the internet running winXP (I have a dual boot configuration) I'm using the built in winXP dialer for ADSL modems.

    I've tried using kppp, but that will only allow PPP connection, whereas as far as I know I require PPPOE.
    I've read about some scripts but I'm not sure it will help me much if I can't even activate the modem...

    If anyone knows how to connect, I'll be happy to get some advise....

    10x,
    Grupy.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You should be using the rp-pppoe package. If you're using RedHat or Mandrake (and probably others), it should have been included in the installation.

    To set it up, start a terminal emulator, become root by running "su -", and then run "adsl-setup". AFAIK, that should take care of just about everything.

  3. #3
    Just Joined!
    Join Date
    Jan 2004
    Posts
    6
    Thanks! but....
    I've tried using adsl-setup (I have RH9 installed), bit still could not connect...

    This is what I get after running and waiting for a prompt from: /sbin/ifup ppp0

    [root@Linux root]# /sbin/adsl-status /etc/sysconfig/network-scripts/ifcfg-ppp0
    Note: You have enabled demand-connection; adsl-status may be inaccurate.
    adsl-status: Link is down (can't read pppoe PID file /var/run/pppoe-adsl.pid.pppoe)

    I've checked and there's no such file in /var/run ...

    So, now what? Can I create such a file?
    Grupy.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    While you could create that file, that won't help at all, since it has to create the right information and correspond to a running process. Instead, check the log file by running "tail -20 /var/log/messages" after running ifup, and see if it contains any useful messages.

  6. #5
    Just Joined!
    Join Date
    Jan 2004
    Posts
    6
    Thanks again...

    I've tried using the tail command (it's really cool - a lot of info ), and I saw that I fail to authenticate.
    I've tried talking to my ISP, but they don't know and don't support linux...!
    Guess I'll have to stay with win for www connections....

    Cheers for all your help!

    grupy.

  7. #6
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    i dotn have broadband so arent familiar with that program but does it have different password formats or authentication methods? im sure ur isp would tell u what one they use. mayeb this could be ur problem. then theres always "have u typed ur password correctly?"

  8. #7
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    It's the same protocol used by both Windows and Linux, so there aren't any apparent reasons why it shouldn't work, unless you were given a driver CD or the like by your ISP.
    There are always possibilities, of course, but I'd say the most likely is that you configured something wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •