Find the answer to your Linux question:
Results 1 to 9 of 9
Hi there. I am having trouble running Mandrake 9.2 on an Acer Travelmate 252LC. The machine came with XP on, and I did a CD install. My first problem was ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Posts
    5

    Freeze booting kernel 2.4.22-10mdk: mdk 9.2, Acer TM252LC


    Hi there.

    I am having trouble running Mandrake 9.2 on an Acer Travelmate 252LC.
    The machine came with XP on, and I did a CD install. My first problem was that after the "hit enter to upgrade or install prompt", the install would hang on a blank screen. Using F1 and text mode showed me that the install was hanging booting the kernel (which was 2.4.22-10mdkBOOT).

    So, I ran the install with the alternate kernel (2.2.19-BADZ5). This worked fine, although I got two error messages along the way:

    -after detecting USB devices, I got: Error: we now use kernel PCMCIA support and this won't work with a 2.2 kernel.

    -a bit later (before being prompted for keyboard layout, I think), I got:
    PCMCIA support no longer exists for 2.2 kernels. Please use a 2.4 kernel.

    Despite these errors, the install went OK, and I updated the XP boot.ini file to use LILO text mode (and XP boots fine).

    However, when I try to boot linux now, the system hangs booting the kernel again. Booting using "linux-nonfb" to get more messages shows it's hanging on:
    Uncompressing Linux... Ok, booting the kernel

    I have tried booting using noapic, nolapic, nopcmcia - none of these seem to work. By using a rescue disk, I've discovered that all the linux options in LILO are trying to load the 2.4.22-10mdk kernel (which was hanging during installation). However, I have no idea how to put a different kernel there for use by LILO.

    Thanks for any advice
    TheKro

  2. #2
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    use a resuce/boot cd or somethign to get write access to the /etc/lilo.conf file.

    edit the line that says
    image=/boot/vmlinuz-2.4.22-10mdk

    for the entry labelled linux or mdk or whatever its called.

    before this, check what kernels u have installed, by tpying ls /boot

    if u specify anythign other than an availible kernel it wont load.

    I doubt the problem is not fixable. Try adding acpi=off and (i think its this) pcmcia=off

  3. #3
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Would you mind trying another distro? Different distros use very different installation kernels and work very differently good on different exotic hardware.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Jan 2004
    Posts
    5
    Dolda2000: Thanks for the suggestion - I'm rather sold on RedHat/Mandrake, since I've been using them pretty much exclusively for about 8 years now, but if all else fails, I guess I'll have to try something else.

    Hellmasker: I don't have any other kernels in /boot. It puzzles me that mandrake only installs one kernel into my /boot, particularly when it's not the kernel I booted for installation. I have tried booting with acpi=off and nopcmcia - also didn't help, unfort.

    Thanks
    TheKro

  6. #5
    Just Joined!
    Join Date
    Jan 2004
    Posts
    5
    Bit of an update:

    Just tried knoppix - the version on our archive is 3.3Beta, using kernel 2.4.22-xfs.

    The CD freezes at exactly the same space as my mandrake install:

    Loading vmlinuz.......
    Loading miniroot.gz
    <screen clears>
    Uncompressing Linux.......Ok, booting the kernel.
    <Freezes>

    (I only get the last message using vga=normal or the knoppix-txt boot choice - otherwise the screen just goes blank.)

    TheKro

  7. #6
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    hers a plan, download a binary kernel (ie. precompiled) and then boot off the install disk using whatever kernel u have to. then install this new kernel, then try to reboot using it.

  8. #7
    Just Joined!
    Join Date
    Jan 2004
    Posts
    5
    I can't see how to get any kernel I download, onto the system to install it.
    If I boot off install disk, I can't mount my windows partition or a memory stick. I can't fit the kernel onto a floppy (formatted with e2fs), so how do I transfer the kernel onto the Linux filesystem?

    TheKro

  9. #8
    Just Joined!
    Join Date
    Jan 2004
    Posts
    5
    Hmm, tried slackware 8.1 and 9.1 installs. Both of them had no problem
    booting the "bare.i" kernel (default - 2.4.18 for 8.1, and 2.4.22 for 9.1).

    So what can I do to keep running mandrake, and not have to install some other distro?

    Also, can I possibly boot the slackware cd, get it mounted, and get it's working 2.4.22 kernel onto my mandrake box. Will this work?

    TheKro

  10. #9
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    ur memory stick might need special driver sso i wouldnt try it from a boot cd, but the windows partitions can be accessed by typing

    fdisk -l /dev/hda (to finnd out what partition is windows if u dont already know)
    mkdir /mnt/win_hd
    mount -t vfat /dev/hda1 /mnt/win_hd

    (replace hda1 with whatever the widnows aprtition is)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •