Find the answer to your Linux question:
Results 1 to 5 of 5
Greek is the native language in my country so i searched the internet for instructions on how to install greek fonts and set greek localization on my linux box (Mandrake ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96

    Filenames in Linux and Kernel Tuning


    Greek is the native language in my country so i searched the internet for instructions on how to install greek fonts and set greek localization on my linux box (Mandrake 9.2 / Fedora Core 1). I visited the site www.linux.gr which is something similar to www.linux.com that offers such instructions written specifically for greek linux users.
    There are also instructions on how to view filenames in linux, windows partitions and removable drives written in greek.
    In the instruction manual says that the following settings must be made to the kernel but it doesn't say how!

    CONFIG_NLS=y
    CONFIG_NLS_DEFAULT="iso8859-7"
    CONFIG_NLS_CODEPAGE_437=m
    CONFIG_NLS_CODEPAGE_737=m
    CONFIG_NLS_CODEPAGE_869=m
    CONFIG_NLS_ISO8859_1=m
    CONFIG_NLS_ISO8859_7=m
    CONFIG_NLS_UTF8=m

    Also in File System- --> Native Language Support i must add the following:
    Default NLS Option: "iso8859-7"
    Codepage 437 (United States, Canada)
    Codepage 737 (Greek)
    Codepage 869 (Greek)
    NLS ISO 8859-1 (Latin 1; Western European Languages)
    NLS ISO 8859-7 (Modern Greek)
    NLS UTF8

    There is also some instruction for editing the /etc/fstab file with the necessary adjustments to view greek in filenames. That part i understood fine. What i don't know is what files i should edit or what actions i should take in order to make the above settings in the kernel.

    I would appreciate any help you give me considering the fact that i ask a questions specific about greek settings.

  2. #2
    Linux User
    Join Date
    May 2003
    Location
    CA
    Posts
    370
    i guess you would have to modify the .config file in the /usr/src/linux directory and re-compile the whole thing.
    i'm not sure so you might want to wait and see if someone else replies to this post.
    Fixing Unix is better than working with Windows.
    http://nikhilk.homedns.org/projects/index.html

  3. #3
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    im afraid that look slike a kernel config file liek nikhil said.

    do u have the kernel sources installed? if nto download them from www.kernel.org for redhat sources, for mandrake sources (which have some extra stuff in them) go to rpm.pbone.net, set it to mandrake releases only, and search for kernel-source and download whatever one u want, probably 2.4.23 or 2.6.0.

    run make xconfig and set as much as possible to modules, then set anything else that sounds useful to yes.

    when u click save and exit, open up a text editor and edit the file /usr/src/linux/.config . Find the lines that u said needed changing, and set them to whatever u want.

    run
    make dep
    make bzImage
    make modules
    make modules_install
    make install

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    You probably don't actually have to do that at all, since most distro kernels come with NLS modules prebuilt. See if you have anything in /lib/modules/2.4.xxx/kernel/fs/nls.

  5. #5
    Just Joined!
    Join Date
    Jun 2003
    Location
    Cyprus
    Posts
    96
    Well i am in Greece for holidays at the moment (my university starts on the 26th ) so i can't really see if this is true Dolda2000. My laptop still runs on Winblows! Thanks for your answer thlough and i'll let you know how it goes when i return to Cyprus on the 18th.
    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •