Find the answer to your Linux question:
Results 1 to 6 of 6
Hi everyone. I'm still relatively new to Linux but I've been getting my hands dirty with kickstart recently. Anyway I seem to be getting some odd results now kickstart is ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Nov 2005
    Posts
    17

    Kickstarting - Some distros work, some don't!


    Hi everyone. I'm still relatively new to Linux but I've been getting my hands dirty with kickstart recently.

    Anyway I seem to be getting some odd results now kickstart is set up. The whole kickstart process is working but for whatever reason, some distributions install just fine and others fail at various points either during installation or during boot.

    I'm doing network installs from a directory containing all files from CD's/DVD's (used cp -Ru)

    Heres a list of the distros i've tried:

    ------------------------------------------------------------------------------------------------

    Fedora 2 "Id "x" respawning too quickly" message upon booting after installation, command line seems fine but GUI doesn't display.

    Fedora 3 - Installs but I'm getting some really odd graphics displayed upon boot, all sorts of random coloured lines vertically up the screen. Sometimes it will boot into the graphical front end, other times i get the colours and have to reboot manually

    Fedora 4 - Works perfectly

    Redhat 9 - Just as the graphical installation begins it drops back to console and gives a traceback of errors relating to kickstart.py - see bottom for more detail.

    Redhat Enterprise ES 3 - This also failed but i cant remember why, will try again and post back.

    Redhat Enterprise ES 4 - "Id "x" respawning too quickly" message upon booting, command line seems fine but GUI doesn't display.

    Redhat Enterprise WS 4 - Works perfectly

    -------------------------------------------------------------------------------------------------

    So 2 installations out of 7 work....pretty dreadful really and makes kickstart pointless if we cant choose the installation we want

    Any ideas as to the cause of any of the errors would be fantastic. If anymore information is required i'll post it up.

    Thanks for your time,

    Lewis



    ------------------------------------------------------------------------------------------------
    Heres the traceback from the RH9 installation:

    1...2..3..4...5...X sercer started successfully
    Traceback (most recent call last)
    File "/usr/bin/anaconda" Line 705 in ?
    instClass.setInstallData(id)
    File "/usr/lib/anaconda/kickstart.py" line 1154, in setInstallData
    self.readKickstart(id, self.file)
    File "/usr/lib/anaconda/kickstart.py" line 668 in readKickstart
    handlers[args[0]](id, args[1:])
    File "/usr/lib/anaconda/kickstart.py" line 97 in doFirewall
    ['dhcp', 'ssh', 'telnet', 'smtp','http','ftp',
    File "/usr/lib/anaconda/isys.py", line 394, in getopt
    return apply(_isys.getopt, args)
    TypeError: bad argument --enabled: unknown option

    install exited abnormally
    .....goes on closing everything then "safe to repoot" message.

    -------------------------------------------------------------------------------------------------


    EDIT:: I just tried Redhat ES3 from disc and it works fine so the discs aren't corrupt. Im not sure if the way i'm copying the files from the iso's / discs matters but i've been working my way from the last disc / iso using "cp -Ru" into a single folder so i've ended up with all the files.

  2. #2
    Just Joined!
    Join Date
    Apr 2006
    Location
    Europe
    Posts
    46
    Welcome to Linux! Not being able to install a distro on one computer is not unlikely. Sometimes it is just hardware issues - unsupported devices, or even as simple as the machine not having enough RAM. I have distros that I can't install on my laptop because most operating systems (Win 2003, for example) do not support all of its hardware, so I just stick to what can be installed on it and the other distros I install on a different machine. So my advice is - I hope you have not bet your life on it () - just install and use what is up and running on your computer and don't bother with the rest, especially old versions.

  3. #3
    Just Joined! asif2k's Avatar
    Join Date
    Feb 2006
    Location
    TEXAS
    Posts
    59
    hardware issues are very common in linux

  4. #4
    Just Joined!
    Join Date
    Nov 2005
    Posts
    17
    Just to let you know it was a hardware issue. Quite strange errors for that I though but yea, with a newer PC every distribution installs flawlessly.

    Thanks for the responses,

    Lewis

  5. #5
    Just Joined!
    Join Date
    Apr 2006
    Location
    Europe
    Posts
    46
    Yes - the usual suspect: hardware. It is great that all distros that you need work on your new PC. But if you encounter a distro that will not install (or at least not without enough efforts on your side) just try it on a different machine - even an older one with the "proper" hardware could be the solution. Nowadays computer addicts usually have at least two machines, so it is less of a problem to find an alternative computer.

  6. #6
    Linux Guru techieMoe's Avatar
    Join Date
    Aug 2004
    Location
    Texas
    Posts
    9,496
    Quote Originally Posted by tana
    Nowadays computer addicts usually have at least two machines, so it is less of a problem to find an alternative computer.
    Or multiple sets of interchangeable parts for the same machine, in my case.
    Registered Linux user #270181
    TechieMoe's Tech Rants

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •