Find the answer to your Linux question:
Results 1 to 2 of 2
Ok, so I have two hard drives, one is 80GB and the other is 40. I have Linux on the bigger one, (which is also master) and Windows ME on ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2004
    Posts
    1

    "Segmentation fault" when booting. Lilo, Mandrake


    Ok, so I have two hard drives, one is 80GB and the other is 40. I have Linux on the bigger one, (which is also master) and Windows ME on the smaller one (slave, obviously.)

    I have had Mandrake 9.1 for a while now, and it has worked fine (Windows has booted fine too), but one day, when I was configuring my desktop, the whole thing crashed and nothing worked anymore. So I rebooted, and when I chose Linux from Lilo, it showed me a message that was something like this (found this from Google, somebody else had the same problem - I didn't remember it exactly :P No answer, homewer):

    INIT: version 2.84 booting
    /etc/rc.d/rc.sysinit: line 44: 21 Segmentation fault grep -q quiet
    /proc/cmdline
    Setting default font (lat0-16): /etc/rc.d/rc.sysinit: line 97: 30
    Segmentation fault grep -q '^LIBSAFE=yes$' /etc/sysconfig/system
    [OK]
    Booting, please wait...

    And that's it, Linux doesn't boot. So, where's the problem? I probably could use the rescue thingy of the installation cd to correct this, but the problem is, that I'm still pretty newbie with Linux and don't know how to do that :P I've tried to install the bootloader again, didn't work.

    Thanks

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    I'm sorry to say so, but it's either a hardware fault, or you've been cracked. If it's a hardware fault, it can probably be detected by the software at http://www.memtest86.com/. If you've been cracked, the easiest solution is probably to reinstall the system.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •