Find the answer to your Linux question:
Results 1 to 3 of 3
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Nov 2002
    Queens, NY

    .Xresources & .emacs Redhat

    Can anyone post their .Xresources and .emacs file defaulted from redhat? Help is greatly appreciated.
    The best things in life are free.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Täby, Sweden
    ;; Red Hat Linux default .emacs initialization file
    ;; Are we running XEmacs or Emacs?
    (defvar running-xemacs (string-match "XEmacs\\|Lucid" emacs-version))
    ;; Set up the keyboard so the delete key on both the regular keyboard
    ;; and the keypad delete the character under the cursor and to the right
    ;; under X, instead of the default, backspace behavior.
    (global-set-key [delete] 'delete-char)
    (global-set-key [kp-delete] 'delete-char)
    ;; Turn on font-lock mode for Emacs
    (cond ((not running-xemacs)
           (global-font-lock-mode t)
    ;; Visual feedback on selections
    (setq-default transient-mark-mode t)
    ;; Always end a file with a newline
    (setq require-final-newline t)
    ;; Stop at the end of the file, not just add lines
    (setq next-line-add-newlines nil)
    ;; Enable wheelmouse support by default
    (cond (window-system
    #ifdef COLOR
    *customization: -color
    emacs*Background: DarkSlateGray
    emacs*Foreground: Wheat
    emacs*pointerColor: Orchid
    emacs*cursorColor: Orchid
    emacs*bitmapIcon: on
    emacs*font: fixed
    emacs.geometry: 80x25
    Seyon.modems: /dev/modem
    xterm*background: Black
    xterm*foreground: Wheat
    xterm*cursorColor: Orchid
    xterm*reverseVideo: false
    xterm*scrollBar: true
    xterm*reverseWrap: true
    xterm*backarrowKey: false
    xterm*eightBitInput: false
    xterm*font: fixed
    xterm*fullCursor: true
    xterm*scrollTtyOutput: off
    xterm*scrollKey: on
    xterm*VT100.Translations: #override\n\
    	<KeyPress>Prior &#58; scroll-back&#40;1,page&#41;\n\
    	<KeyPress>Next &#58; scroll-forw&#40;1,page&#41;
    xterm*titleBar&#58; false
    xterm_color*background&#58; Black
    xterm_color*foreground&#58; Wheat
    xterm_color*cursorColor&#58; Orchid
    xterm_color*reverseVideo&#58; false
    xterm_color*scrollBar&#58; true
    xterm_color*saveLines&#58; 5000
    xterm_color*reverseWrap&#58; true
    xterm_color*font&#58; fixed
    xterm_color.geometry&#58; 80x25+20+20
    xterm_color*fullCursor&#58; true
    xterm_color*scrollTtyOutput&#58; off
    xterm_color*scrollKey&#58; on
    xterm_color*VT100.Translations&#58; #override\n\
    	<KeyPress>Prior &#58; scroll-back&#40;1,page&#41;\n\
    	<KeyPress>Next &#58; scroll-forw&#40;1,page&#41;
    xterm_color*titleBar&#58; false

  3. #3
    Linux Engineer
    Join Date
    Nov 2002
    Queens, NY


    Thanks dolda. I had to redo my debian system and I forgot to save those redhat files from a previous installation.
    The best things in life are free.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts