Find the answer to your Linux question:
Results 1 to 2 of 2
Hello All, I have installed Red Hat Linux Enterprise 3 ona PC that once had Windows XP. I installed GRUB as boot loader. Everything worked fine, able to log-in, create ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2006
    Posts
    2

    Problems with Linux & Linux dual boot


    Hello All,

    I have installed Red Hat Linux Enterprise 3 ona PC that once had Windows XP. I installed GRUB as boot loader. Everything worked fine, able to log-in, create accounts, install applications, etc.. Then, there was a need to test an application that only runs on Red Hat Linux - 8., so I partitioned the 40 Gb hard drive (30 for existing Enterprise-3 and 10 Gb for RHL-8 ) using Druid. The disk had following partitions:
    /dev/hde1 - ext3
    /dev/hde2 - ext3
    Free
    /dev/hde3 - swap

    I used the auto-assign option on Free slice and it assigned "free" to /dev/hde4, which in turn sliced into 3 partitions as /dev/hde5, /dev/hde6, and /dev/hde7. I went ahead to install RH Linux - 8 in /dev/hde5. During, installation of RH Linux - 8, I chose not to install the boot loader. But when it came to format the swap partition, it did not give me any option to choose a particular swap area, and formatted both /dev/hde3 & /dev/hde7.

    When I completed the installtion, there was something amiss. So, I re-installed RH Linux-8. But this time, I think I made the tragic error of installing RH Linux-8 GRUb over previous installation of Linux Enterprise-3. Now I see a boot option for RH Linux-8 but can't boot into Enterprise-3. Also, if I try to boot into RH Linux-8, it just hangs after reaching certain point.

    Things weren't bad enough, so, I went ahead and deleted the partition where I installed RH-8 thinking that I will start afresh. I also tried to use Enterprise install CD, and typed Linux rescue at the prompt. But then it tells me that it could not find hard disk. Where as I put RH linux-8 install CD, it doesn't complain about hard disk not present. Rather I am able to reach the point where I can partition the drive.

    I know I am in deep-deep sh**t, but someone please tell me that there is a way out, and help me.

    Thanks.

  2. #2
    Just Joined!
    Join Date
    May 2006
    Posts
    2
    Never mind, I manage to resolve the issues.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •