just switched over and installed Ubunto as the second HD slave.Same problem, Can't mount second HD (slave).On Grub boot I have fedora 5 which will boot if I select it and Ubunto after I select to boot Ubunto I get this "Error 13 Invalid or unsupported executionable format" Do I need to add to etc/fstab and /etc/mtab? I don't know what to add and how to do it, Need help. Thanks
Here is my /boot/grub
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You have a /boot partition. This means that
# all kernel and initrd paths are relative to /boot/, eg.
# root (hd0,0)
# kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
# initrd /initrd-version.img
#boot=/dev/hda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
#hiddenmenu
title Fedora Core (2.6.16-1.2111_FC5)
root (hd0,0)
kernel /vmlinuz-2.6.16-1.2111_FC5 ro root=/dev/VolGroup00/LogVol00
initrd /initrd-2.6.16-1.2111_FC5.img
title Fedora Core (2.6.15-1.2054_FC5)
root (hd0,0)
kernel /vmlinuz-2.6.15-1.2054_FC5 ro root=/dev/VolGroup00/LogVol00
initrd /initrd-2.6.15-1.2054_FC5.img
title Ubuntu 5.10
map (hd0) (hd1)
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader (hd1,0) +1

Here is my /etc/fstab
/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/hdb1 /mnt/hdb1 ext3 defaults 1 3

Here is my /etc/mtab
/dev/mapper/VolGroup00-LogVol00 / ext3 rw 0 0
proc /proc proc rw 0 0
sysfs /sys sysfs rw 0 0
devpts /dev/pts devpts rw,gid=5,mode=620 0 0
/dev/hda1 /boot ext3 rw 0 0
tmpfs /dev/shm tmpfs rw 0 0
/dev/hdb1 /mnt/hdb1 ext3 rw 0 0
none /proc/sys/fs/binfmt_misc binfmt_misc rw 0 0
automount(pid1895) /net autofs rw,fd=4,pgrp=1895,minproto=2,maxproto=4 0 0
Hope this helps? Thanks