Find the answer to your Linux question:
Results 1 to 2 of 2
Alright im tryin to get XGL working with suse 1.10 and soo i follow the tutorial on the novell site [URL="http://www.novell.com/coolsolutions/feature/17174.html"]l and i go to put the command for the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2006
    Posts
    1

    Nvidia Driver problems..


    Alright im tryin to get XGL working with suse 1.10 and soo i follow the tutorial on the novell site [URL="http://www.novell.com/coolsolutions/feature/17174.html"]l and i go to put the command for the driver file and i get it to come up and it gives me this error

    The kernel header file
    '/lib/modules/2.6.13-15.10-smp/build/include/linux/kernel.h' does not
    exist. The most likely reason for this is that the kernel source path
    '/lib/modules/2.6.13-15.10-smp/build' is incorrect. Please make sure
    you have installed the kernel source files for your kernel and that they
    are properly configured; on Red Hat Linux systems, for example, be sure
    you have the 'kernel-source' RPM installed. If you know the correct
    kernel source files are installed, you may specify the kernel source
    path with the '--kernel-source-path' command line option.


    and iam new to this soo if anyone could be of any help please let me know.. Thank you

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,133
    You need to install your kernel source. Go into YaST > Software > Software Management and search for 'kernel source'. Just tick the box. You may also have to search for gcc and make if you do not have them installed. Once you are finished this bit it should work. Can I add, that howto is quite out of date and was written for beta releases. When you have the nVidia driver installed, Just go to the Gnome-Contol-Center and launch the 3D Desktop module, that will look after the rest for you.
    Alternatively from the command line -
    Code:
    gnome-xgl-switch --enable-xgl

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •