Find the answer to your Linux question:
Results 1 to 7 of 7
I am new to Linux and not sure which forum this goes in but here is my problem. I am attempting to install the new kernel rpm's for RH9. the ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    6

    NEED HELP UPGRADING RH9


    I am new to Linux and not sure which forum this goes in but here is my problem. I am attempting to install the new kernel rpm's for RH9. the 2.4.20-28.9.athlon, and then the source for that kernel aswell.

    When I double click on them in gnome, the *.athlon.rpm comes up with the checking dependencies, the window closes and then nothing happens. The source.rpm does nothing.

    When I try it in terminal, i use the rpm -i [filename] command and for the *.athlon.rpm it says that it has NOKEY and that it cannot write or open the var/lib/rpm directories. I also tried the rpm -U command and the same thing happend.

    When I try the *source.rpm, it says that I do not have permission or something like that to open the %sourcedir and then some path that I forgot.

    Any help would be MUCH appreciated. This is driving me crazy, and I am sure it is something simple, but I just started on Linux today so I do not have much of an idea about the terminal commands.

  2. #2
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    you can try urpmi... it's supposed to be better than rpm... not sure on its usage though.. to find out, type this at a shell prompt:
    Code:
    man urpmi
    the GUI rpm utility is known to be broken and not worth a damn.. not sure what the command line errors, are, though.. i think it has to do with the way the package is (not?) signed with RH's GPG keys...
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  3. #3
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Are you installing the RPM as root
    Sounds like you are using your normal user account.
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    Yea, make sure you are root and also try

    To test install:
    rpm -ivh --test pkgname

    To install:
    rpm -ivh pkgname

    To update:
    rpm -Uvh pkgname


    Here's a list of rpm commands
    http://uw713doc.sco.com/en/LX_uw/LKP_rpm_commands.html

  6. #5
    Just Joined!
    Join Date
    Feb 2004
    Posts
    6
    I will try the other suggests too. But how would I change to root, and not be in my local user account? Thanks again.

  7. #6
    Linux Newbie
    Join Date
    Sep 2003
    Location
    St.Charles, Missouri, USA
    Posts
    201
    use the "su" command to change to root and everything (hopefully) should work. Good luck
    Powered by Gentoo
    never ever ever use the hardened option in make.conf!

  8. #7
    Just Joined!
    Join Date
    Feb 2004
    Posts
    6
    thanks very much that worked and I was able to install the kernel update. However, I still have a problem with the src update. When I try to install it in terminal, it says that it cannot create %sourcedir . . . /usr/. . . ./SOURCE

    I forgot the stuff in between. Any idea why this is still happening to me? I am root now. This whole thing started when I tried to get my nforce network card working. I need the kernel src to make the driver from the .tar

    Any help would be appreciated. This is my second day on linux, and its already better than MS

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •