Find the answer to your Linux question:
Results 1 to 5 of 5
i am a total linux newbie. so plz be patient and less technical in explaining. 1.i have 2 harddisks : 80 gb sata and 20 gb pata. i have windows ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    6

    Exclamation anothor boot problem!!!!!!!!!!!!!!


    i am a total linux newbie. so plz be patient and less technical in explaining.

    1.i have 2 harddisks : 80 gb sata and 20 gb pata.
    i have windows xp installed on sata . (it has four partitions of 20gb each . i dont know if its relevant or not)

    2.My 20 gb harddisk has iso's of redhat 9 and rest free space.
    created partitions : hdd1 -ex3 6mb
    hdd5- vfat 6mb
    hdd2- ex3 101 mb /boot
    hdd3- 12gb /
    hdd4- 957 mb /linux -swap
    ABOVE information is noted down from the tool "kickstarter" from linux.
    my processor is AMD 64 anthlon 3000+,ram 512 mb.

    3.my way to linux install :
    i ,for some stupid reasons, removed my sata hardisk before installing linux.then using boot cd which i created earlier installed LINUX on the 20gb harddisk successfully (using iso images ).my linux loads with grub boot loader.i am successfully running linux with no problems...

    4.My problem
    i have now connected my sata harddisk permanently.

    when i chose "dos" from intial window (when sytem starts) windows doesnt boot bcos windows is located
    in my sata harddisk.so to boot windows i have to configure my sata as boot drive everytime i want windows.
    and pata as boot drive everytime i want linux.

    i read previous posts some said boot loader shud be on same drive . i tried reinstalling linux and
    when while installing it says that i shud specify the harddisk where the system shud look for booting dos when"dos" will be selected in intial window of system start ,i cudnt find my sata path . (i thought i wud specify the path of my sata c: drive and it will be solved)

    help plz...
    if unclear abt the problem pl tell me that too. i will try to be more lucid.

  2. #2
    Linux User Kojak's Avatar
    Join Date
    Apr 2006
    Posts
    421
    The problem you have is simple to solve. You have the Linux disk as master and connect the Windows disk as slave to your board. In that case, the windows bootloader will not start without a small trick. Windows always wants to reside on the master-drive (it doesn't want to be a slave. Who wants anyway?) and thus refuses to boot on your system. The trick you have to apply here is to change the bootloader entry of your Linux system, in this case "grub". The file that configures your bootloader is located in /boot/grub/grub.conf or /boot/grub/menu.lst. So, if you open e.g. a terminal as root user (type "su", hit enter, type root password, hit enter) and launch

    gedit /boot/grub/menu.lst (or grub.conf)

    an editor will open the bootloader configuration. In there, there will be a section titled DOS (or Windows). The entry there should look like this after you edit it:

    title Windows
    root (hd1,0)
    map (hd1) (hd0)
    map (hd0) (hd1)
    makeactive
    chainloader +1

    The first section tells the bootloader that the heart of the operating system you want to boot (=root) is located on harddisk 1, partition 1. Grub starts counting from 0 instead of 1, so it might be a bit confusing at first, but it is easy once you know this. Now the hd1,0 (harddisk2, partition1) needs to be swapped, so the computer thinks that Windows IS on harddisk1 although it is still on harddisk 2. For that, the "map" command is launched.

    map (hd1) (hd0) = make harddisk 2 to harddisk 1
    map (hd0) (hd1) = make harddisk 1 to harddisk 2

    Both commands are necessary, otherwise you will have e.g. two harddisks 2 but no harddisk 1 and the computer will say "meeh, forget it. I am confused".

    With "makeactive", the swapped partition will be activated and with "chainloader +1", the Windows bootloader will kick in.

    Once all changes are done, save the file and you are done.

    I hope this was understandable and not too technical.


    PS: In case that there is no Windows entry in grub.conf or menu.lst at all, then add

    title Windows
    root (hd1,0)
    makeactive
    chainloader +1

    for now and try to boot Windows with that configuration. If that fails, try what I wrote above with "map blablabla".

    Good luck.
    Windows free since 2002 | computing since 1984

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    6
    thankx for explaining


    tried what ever u told but it didnt help
    it shows"error' when i seleted windows from start screen!

  4. #4
    Linux User Kojak's Avatar
    Join Date
    Apr 2006
    Posts
    421
    If that doesn't work, then it could be caused by using the old RedHat 9. Sata support was very problematic some years ago and hard to fix, but newer Linuxes usually have no problems with it. So, if you have broadband, I suggest you download a newer version of Fedora (the well tested FC4 or the brand-new FC5), which is the official RedHat spinoff since RedHat decided to split its work into Fedora for home users and RHEL for Enterprises, and do a clean install with them. The dualboot should work then.
    Windows free since 2002 | computing since 1984

  5. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    6
    hi all
    i have winxp installed on my 80gb SATA.
    i installed redhat 9 on my 20gb PATA by NOT connecting
    SATA hdd to the cpu for some reasons.i installed grub on mbr.later i came to know that redhat 9 doesnt suppport sata so i cudnt get my linux to dual boot winxp.
    this is the reason why the things that us pll told me werent working!i thank u for ur time and knowledge. B)

    i got fedora 4 recently .so to install it, i formatted my PATA totally by booting using dos and fdisk.i also deleted all the partitions.i think deleting all partitions will erase all records of linux,no?

    now!
    i burn isolinux image of fedora on a cdrom as i am using isos to install it. on rebooting , i pressed enter to log in to graphical mode.
    the booting started and then suddenly i started getting these kind of messages:

    SIS_IDE : probe of 0000:00:02.5 detection with error

    ...things now move very fast i cant see....

    VFS:cannot open root "<NULL>" or unknown boot (8,3).
    please append a correct"root=" boot option
    kernel panic not syncing :VFS unable to mount root fs
    and loads to rubbish...

    then the screen wud get stuck and i wud have to reboot


    i hav tried several times ( even detached my sata to do it and next time pata and next time with both attached(phew..) )but in vain.

    help plz.....


    special thaknx to u kojak


    update : as prescribed in sum forums i put garbage vaalue and then press linux mediacheck.AND fedora starts to install...

    BUT its not detecting any of my harddisks!!!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •