Find the answer to your Linux question:
Results 1 to 2 of 2
a7n8x deluxe with nvidia geforce fx 5900, everything works fine but this agpgart issue.... how should it be configured ?? also i added the option to modules.conf to enable fastwrites ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    7

    nvidia agpgart problems


    a7n8x deluxe with nvidia geforce fx 5900, everything works fine but this agpgart issue.... how should it be configured ?? also i added the option to modules.conf to enable fastwrites and sba but when i cat /proc/driver/nvidia/agp/status it says that fast writes is enabled but SBA is NOT enabled.

    this is the agpgart error in dmesg boot

    0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4496 Wed Jul 16 19:03:09 PDT 2003
    hdc: attached ide-cdrom driver. hdc: ATAPI 40X DVD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
    Uniform CD-ROM driver Revision: 3.12 hdd: attached ide-cdrom driver.
    hdd: ATAPI 48X CD-ROM CD-R/RW drive, 2048kB Cache, UDMA(33)
    SCSI subsystem driver Revision: 1.00
    0: NVRM: AGPGART: unable to retrieve symbol table

    agpgart is disabled in the kernel

  2. #2
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    agpgart needs to be enabled along with the drivers for your pci bridge.. this can be gotten from lspci... i would recommend building them into the kernel.. but that's just my choice.. if you prefer modules, you can use that instead.
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •