Find the answer to your Linux question:
Results 1 to 6 of 6
I have Windows XP Professsional on the first partition of my hard drive, and Ubuntu 6.06 on the second. Ubuntu boots fine, but when I try to boot XP I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jun 2006
    Posts
    21

    Dual Boot XP and Ubuntu HELP Please!


    I have Windows XP Professsional on the first partition of my hard drive, and Ubuntu 6.06 on the second. Ubuntu boots fine, but when I try to boot XP I get this:
    Code:
    Booting 'Microsoft Windows XP Professional
    root (hd0,0)
    Filesystem type unknown, partition type 0x7
    savedefault
    makeactive
    chainloader +1
    A disk read error occurred
    Press ctrl+alt+delete to Restart
    Here is my menu.lst file:
    Code:
    title		Ubuntu, kernel 2.6.15-23-386
    
    root		(hd0,1)
    kernel		/boot/vmlinuz-2.6.15-23-386 root=/dev/hda2 ro quiet splash
    initrd		/boot/initrd.img-2.6.15-23-386
    savedefault
    boot
    
    title		Ubuntu, kernel 2.6.15-23-386 (recovery mode)
    root		(hd0,1)
    kernel		/boot/vmlinuz-2.6.15-23-386 root=/dev/hda2 ro single
    initrd		/boot/initrd.img-2.6.15-23-386
    boot
    
    title		Ubuntu, memtest86+
    root		(hd0,1)
    kernel		/boot/memtest86+.bin 
    boot
    
    ### END DEBIAN AUTOMAGIC KERNELS LIST
    
    # This is a divider, added to separate the menu items below from the Debian
    # ones.
    
    title		Other operating systems:
    root
    # This entry automatically added by the Debian installer for a non-linux OS
    # on /dev/hda1
    
    title		Microsoft Windows XP Professional
    root	(hd0,0)
    savedefault
    makeactive
    chainloader	+1
    please help!

  2. #2
    Linux Engineer rcgreen's Avatar
    Join Date
    May 2006
    Location
    the hills
    Posts
    1,134
    Did the problem start out of the blue, or did it start right
    after installing linux?. You might be able to repair windows
    by booting the microsoft cd, but will have to have a way
    to reinstall the GRUB bootloader afterward.

  3. #3
    Just Joined!
    Join Date
    Jun 2006
    Posts
    21
    The problem started when I installed Ubuntu. I'll restore the MBR using windows cd, and i'll try to get grub back using the ubuntu cd.

  4. #4
    Just Joined! mariana.malta's Avatar
    Join Date
    Jul 2006
    Location
    Matosinhos/Portugal
    Posts
    8
    I have the same problem.

    I wanted to installed windows XP and Edubuntu 6.06 on a brand new PC, same drive 2 partitions, dual boot.

    I had some problems with Edubuntu because of the Intel Graphics card inboard. But after a few attemps with different parameters It worked. Grub installed in MBR perfectly. I was happy. Until....

    when I booted again the pc in Windows it gave me a fatal error. I can boot to Edubuntu but not to Windows. The MBR is ok, but something went wrong with the boot of windows. As I do not uderstand a thing of windows I thought in:
    1. Install windows again in the first partition
    2. Boot with a LInux floppy and then update and install grub on the MBR

    But not possible. This PC doesn't allow me to boot from floppies!

    Then I thought:
    1. Install windows again in the first partition
    2. Boot from LIve Edubuntu
    3. Update and install grub on the MBR

    BEfore installing windows I tried this procedure but:
    In Edubuntu I can mount the windows partition and see all the files that are there, but I am not able to do the chroot to the drive (only one /dev/sda)

    then I thought:
    I boot with Knoppix 4 instead of Live Edubuntu.

    I did it, could see the disk /dev/sda (it mounts it automaticlly) I could chroot to this disk. I could do update-grub but can't actually do what I want: grub-install /dev/sda! it gives me several errors saying that /dev/null is not accessible!

    I am hopeless here...

    The harddrive is new, so I can start all over again because I do not have anything on it as data. But why do I have to install EVERYTHING again if it should be possible to re-do the MBR after a windows installation?

    If I boot with a Windows XP CD and go to the recover mode, what actually should I do? simply "fixmbr"?

    And what happens?

    Can you give me a help?

    Thank you,
    Mariana

  5. #5
    Just Joined!
    Join Date
    Jun 2006
    Posts
    21
    What I ended up doing was booting up the live cd and deleting all of my ubuntu partitions, so only the windows xp partition remained. I figured the problem went in the installation of xp, so i reinstalled it in the same partition. Then for partitioning ubuntu i put it in hda2, and made an extended partition, making swap hda5 and a fat32 partition hda6. Somehow, all of that worked and I had a perfect dual boot! Hopefully this helps.

  6. #6
    Just Joined!
    Join Date
    Sep 2007
    Posts
    1

    Thumbs up My solution

    I ran into this problem when resigning a ntfs partition using ntfsresize from kubuntu 7.04.

    Of course, after installing kubuntu, windows xp would not boot and gave the infamous

    A Disk Read Error Occurred.
    Press Ctrl+Alt+Del

    As an interim solution, and found a cdrom which would boot windows: fixntldr.iso.zip seemed to do the trick.

    It seems that it is a problem with the geometry combined with the hard coding of the geometry into the partition by windows xp.

    The solution I used was this:

    sfdisk -d /dev/hda | sfdisk --force -no-reread -H255 /dev/hda
    hexedit /dev/hda1 (/dev/hda1 was my windows partition)
    [press enter]
    7e1a
    FF
    ctrl-x, "y"
    and that's it.

    The first thing changes the geometry of the partition table to have 255 heads as is expected by windows. The second changes the hard coded byte in the windows partition table to 255 (FF in hex), which is the number of heads in the new partition table.

    And that's it.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •