Find the answer to your Linux question:
Results 1 to 6 of 6
halo ... i have download the g++ 2.96 from this link as below : http://rpm.pbone.net/index.php3/stat....i386.rpm.html But when i tried to install it, error message appears such as below : [root@localhost ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jul 2006
    Posts
    70

    installation problem of g++2.96


    halo ... i have download the g++ 2.96 from this link as below :
    http://rpm.pbone.net/index.php3/stat....i386.rpm.html

    But when i tried to install it, error message appears such as below :

    [root@localhost Desktop]# rpm -Uvh gcc-2.96-69.i386.rpm
    error: Failed dependencies:
    cpp = 2.96 is needed by gcc-2.96-69.i386
    gcc < 2.96-79 conflicts with glibc-devel-2.3.5-10.i386
    gcc = 4.0.0-8 is needed by (installed) gcc-java-4.0.0-8.i386
    gcc = 4.0.0-8 is needed by (installed) gcc-c++-4.0.0-8.i386
    gcc = 4.0.0-8 is needed by (installed) gcc-gfortran-4.0.0-8.i386
    gcc = 4.0.0-8 is needed by (installed) gcc-gnat-4.0.0-8.i386
    gcc = 4.0.0-8 is needed by (installed) gcc-objc-4.0.0-8.i386
    gcc = 4.0.0 is needed by (installed) libtool-1.5.16.multilib2-1.i386
    gcc = 4.0.0 is needed by (installed) apr-devel-0.9.6-3.i386
    gcc = 4.0.0-8 is needed by (installed) libmudflap-devel-4.0.0-8.i386

    When i tried to download the cpp -2.96-69.i386.rpm from below link:

    http://rpm.pbone.net/index.php3?stat...96-69.i386.rpm

    The error message appear as :

    error: Failed dependencies:
    cpp = 4.0.0-8 is needed by (installed) gcc-4.0.0-8.i386

    May i know why it is still related to my current version g++4.0.0 ?

    Did anyone know how to solve the problem ??

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729

    Smile

    hi wahaha !!!

    best way to resolve dependencies is.... using default updater....
    you didnt wrote bout distro... for RH and FC .... its yum... and for SuSe ... its Yast...

    $ yum -y install <package>

    it take care of all dependencies........ ( beauty of yum ).........

    <=== { casper } ===>
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi wahaha,
    Have you already got gcc-4.0.8 installed in your machine?

    The C Preprocessor package and the gcc package that you are trying to install is quite outdated and it will create problems with other newer version of related tools which depend on these packages. So, install the packages that correspond to the version that you have.

    Otherwise, remove all the dependencies that are newer and install the older version, which does not seem to be a good idea, unless you have a solid reason for going for the older version of gcc.

    With Regards,
    Thinker

  4. #4
    Just Joined!
    Join Date
    Jul 2006
    Posts
    70

    halo

    i had tried to type " yum install gcc-2.96" , the message appears as below :

    [root@localhost kokchin]# yum -y install gcc-2.96
    Setting up Install Process
    Setting up repositories
    updates-released 100% |=========================| 951 B 00:01
    extras 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    primary.xml.gz 100% |=========================| 320 kB 00:41
    updates-re: ################################################## 865/865
    Added 181 new packages, deleted 416 old in 6.43 seconds
    Parsing package install arguments
    No Match for argument: gcc-2.96
    Nothing to do

    It seem like cannot install gcc-2.96 by using "yum".

    i had tried to type " yum install gcc-4.0.8" , the message appears as below :

    [root@localhost kokchin]# yum -y install gcc-4.0.8
    Setting up Install Process
    Setting up repositories
    updates-released 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    Parsing package install arguments
    No Match for argument: gcc-4.0.8
    Nothing to do

    Did anyone know why ??

    Sorry to forgot mentioned that i am using fedora core 4, 2.6.11-1.1369_FC4 and i am tried to installed a mobile mesh software into my fedora, and i had posted about it as below:

    http://www.linuxforums.org/forum/lin...n-problem.html

    The latest error message shown from the above link might be due to compiler problem because i had found the another that stated must use g++2.96 as below:

    http://wirelessafrica.meraka.org.za/...hp/Mobile_Mesh

    I know that it also might due to kernel problem because the mobile mesh is only developed for 2.2.X kernel and haven't tested on higher level of kernel.

    If anyone do have an ideas please drop your message on the link. Thx

  5. #5
    Linux User
    Join Date
    Jun 2006
    Posts
    311
    Hi wahaha,
    Run the following command to update gcc to it latest version : -
    # yum -y update gcc
    Did you try installing the software from source on the current version of gcc that you already have on your machine? Possibility of getting it working, may be less, as it was built for a very old version of Linux kernel, still but it is worth giving a try.

    With Regards,
    Thinker

  6. #6
    Just Joined!
    Join Date
    Jul 2006
    Posts
    70

    halo thinker

    after i typed "yum -y update gcc", the error message still appear( a bit different from previous error message) as below when i tried to install the gcc-2.96-69.i386.rpm :


    [root@localhost Desktop]# rpm -Uvh gcc-2.96-69.i386.rpm
    error: Failed dependencies:
    cpp = 2.96 is needed by gcc-2.96-69.i386
    gcc < 2.96-79 conflicts with glibc-devel-2.3.5-10.i386
    gcc = 4.0.2-8.fc4 is needed by (installed) libmudflap-devel-4.0.2-8.fc4.i386
    gcc = 4.0.2-8.fc4 is needed by (installed) gcc-objc-4.0.2-8.fc4.i386
    gcc = 4.0.2-8.fc4 is needed by (installed) gcc-gfortran-4.0.2-8.fc4.i386
    gcc = 4.0.2-8.fc4 is needed by (installed) gcc-java-4.0.2-8.fc4.i386
    gcc = 4.0.2-8.fc4 is needed by (installed) gcc-c++-4.0.2-8.fc4.i386
    gcc = 4.0.2-8.fc4 is needed by (installed) gcc-gnat-4.0.2-8.fc4.i386
    gcc = 4.0.2 is needed by (installed) apr-devel-0.9.6-3.5.i386
    gcc = 4.0.2 is needed by (installed) libtool-1.5.16.multilib2-3.i386

    when i tried to install the cpp, the error still the same:


    [root@localhost Desktop]# rpm -Uvh cpp-2.96-69.i386.rpm
    error: Failed dependencies:
    cpp = 4.0.2-8.fc4 is needed by (installed) gcc-4.0.2-8.fc4.i386

    When i tried to install cpp-4.0.3-8.fc4, the message shown below :

    [root@localhost Desktop]# yum install cpp-4.0.2-8.fc4
    Setting up Install Process
    Setting up repositories
    updates-released 100% |=========================| 951 B 00:00
    extras 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    primary.xml.gz 100% |=========================| 391 kB 00:18
    updates-re: ################################################## 1100/1100
    Added 416 new packages, deleted 197 old in 6.79 seconds
    Parsing package install arguments
    Nothing to do


    I really got no idea what should i do now. Is it possible that by removing the g++4.0.0 and then install the g++2.96 . But it look like not realistic way because i did tried to install the g++2.96 by typed " yum install gcc-2.96", but the error message shown below:

    [root@localhost Desktop]# yum install gcc-2.96
    Setting up Install Process
    Setting up repositories
    http://mirror.netglobalis.net/pub/fe...ta/repomd.xml: [Errno 4] IOError: HTTP Error 404: Date: Tue, 25 Jul 2006 15:14:02 GMT
    Server: NOYB
    Content-Length: 318
    Connection: close
    Content-Type: text/html; charset=iso-8859-1
    Trying other mirror.
    updates-released 100% |=========================| 1.2 kB 00:00
    extras 100% |=========================| 1.1 kB 00:00
    base 100% |=========================| 1.1 kB 00:00
    Reading repository metadata in from local files
    primary.xml.gz 100% |=========================| 325 kB 00:06
    updates-re: ################################################## 881/881
    Added 197 new packages, deleted 416 old in 4.81 seconds
    Parsing package install arguments
    No Match for argument: gcc-2.96
    Nothing to do

    It seem like the "yum" cannot find any compiler for gcc-2.96 for fedora core 4, 2.6.11-1.1369_FC4 or not able to support it.

    Did anyone know why ? Please drop your message here if you have any ideas. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •