Find the answer to your Linux question:
Results 1 to 5 of 5
Hi, i have a little problem with installation Opera7.50 - needed to install libstdc++-libc6.1-2.so.3 (i have it) i tried: > gunzip libstdc++-libc6.1-2.so.3.gz > cp libstdc++-libc6.1-2.so.3 /usr/local/lib > chmod a+rx /usr/local/lib/libstdc++-libc6.1-2.so.3 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2004
    Posts
    25

    how to install(or add) lib...


    Hi,

    i have a little problem with installation Opera7.50
    - needed to install libstdc++-libc6.1-2.so.3 (i have it)

    i tried:

    > gunzip libstdc++-libc6.1-2.so.3.gz
    > cp libstdc++-libc6.1-2.so.3 /usr/local/lib
    > chmod a+rx /usr/local/lib/libstdc++-libc6.1-2.so.3
    > ldconfig

    but its not working ....

    please help....

    mandrake 9.2 / kernel > 2.4

  2. #2
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    See if you have a library installed that is close to the one that is causing the error.

    Code:
    ls -l libstdc++*
    If you see something like libstdc++-libc6.x-y.so.3 that looks close, then you can create a symbolic link to it, by issuing the following as r00t:

    Code:
    ln -s /usr/lib/libstdc++-3-libc6.x-y.so.3 /usr/lib/libstdc++-libc6.1-2.so.3
    See if that helps.
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  3. #3
    Just Joined!
    Join Date
    Feb 2004
    Posts
    25
    Thanks for answering...

    i tried

    > ls -l libstdc++*

    but the is no any libs with that name...
    may be i can try like this:

    > ln -s /usr/lib/{some diffefent lib} /usr/lib/libstdc++-libc6.1-2.so.3

  4. #4
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    try installing the compat-libstdc++ package.. some programs need an older version of the C/C++ libs... that package makes sure that they are there..
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  5. #5
    Just Joined!
    Join Date
    Feb 2004
    Posts
    25
    I have already installed compat-libstdc++ libs ...

    i thing i have to wait for a newer version of Opera7.5*(with no libstdc++-libc6... or added) or may be i can install some RPM manager that will ask : do you want to install opera with out libstdc++-libc6...(i remember it was in RedHat 7)...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •