Find the answer to your Linux question:
Results 1 to 3 of 3
I've been experiencing some ongoing Linux-related frustration for a while now, and I'm hoping I can get an explanation or solution. Basically, flavors of Linux based on the 2.6 kernel ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2005
    Posts
    13

    2.6 kernel???


    I've been experiencing some ongoing Linux-related frustration for a while now, and I'm hoping I can get an explanation or solution.

    Basically, flavors of Linux based on the 2.6 kernel do not work on either my desktop or laptop. 2.4? Sure, no problem! In fact, I used to have a very smooth-running Debian/KDE/2.4 desktop running that I installed from the ground up. I finally gave up on it for several reasons, but for the most part it worked very well.

    I'd like to play around with some of the latest distros (Ubuntu, ZenLive, Suse, etc.) but because they're all 2.6-based I simply can't. It's very frustrating and I'd like to know what the problem is.

    The invariable error that I get upon booting anything 2.6 is related to udev/hotplug/coldplug. The error messages are cryptic to the extreme, always centering around a kernel panic. Here's the one I got just now from ZenLive:

    Unable to handle kernel NULL pointer dereference at virtual address 0000007b
    printing eip:
    c0103dc5
    *pde = 00000000
    Recursive die() failure, output suppressed
    <0>Kernel panic - not syncing: Fatal exception in interrupt

    I get a similar error on my laptop and, get this, in a Virtual PC VM!

    Here is my desktop system:

    Intel Celeron 1.8GHz, overclocked to 2.25Ghz
    760 MB RAM
    P4TGV-R motherboard
    * Socket 478
    * North Bridge: Intel 845GV
    * South Bridge: Intel ICH4
    * Super I/O chip ITE IT8712F
    * Award BIOS
    Maxtor 6Y080L0 80GB hard drive (master)
    Maxtor 6Y120P0 120GB hard drive (slave)
    NVIDIA GeForce4 MX 4000 PCI graphics card (64MB)
    Sony DVD RW DW-D26A DVD burner
    Standard 3.5 floppy drive
    Microsoft PS/2 Keyboard (IntelliType Pro)
    Microsoft PS/2 Port Mouse (IntelliPoint)
    1394 Net Adapter (NEC OHCI Compliant IEEE 1394 Host Controller)
    Realtek RTL8139/810x Family Fast Ethernet NIC
    M-Audio MobilePre USB sound device
    Samsung ML-2010 (USB)
    Epson Stylus Photo R220 (USB)

    That's it! Everything has been working flawlessly for two+ years using Windows XP Home and, as I mentioned before, any flavor of Linux based on the 2.4 kernel.

    My question: what is the problem that the 2.6 kernel is encountering? How do I avoid it? What do these crazy error messages mean?

    Any assistance or insight is greatly appreciated!

  2. #2
    Linux Guru bigtomrodney's Avatar
    Join Date
    Nov 2004
    Location
    Ireland
    Posts
    6,125
    Do you have Windows crash at any time? It is possible that overclocking your CPU has introduced instability. Did you increase the core voltage to stabilise spiking after raising your bus speed?

  3. #3
    Just Joined!
    Join Date
    Mar 2005
    Posts
    13
    The overclocking has been extremely stable under Windows, and I only did it recently. I've been having the 2.6 kernel-related kernel panics for years, long before I tried overclocking.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •