Find the answer to your Linux question:
Results 1 to 3 of 3
hi!! i installed gentoo linux on /dev/hdi. than i reconfigured my computer and my hd was then hde. so i edited fstab and the bootloader to boot my kernel from ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Newbie robak's Avatar
    Join Date
    Jan 2004
    Posts
    136

    linux doesn't boot after hd changed


    hi!!

    i installed gentoo linux on /dev/hdi. than i reconfigured my computer and my hd was then hde.
    so i edited fstab and the bootloader to boot my kernel from /dev/hde

    the kernel does boot without probs but after the kernel was loaded and the hardwarecheck is passed i get this error:

    Code:
    could not load /lib/modules/2.6.3/modules.dep (i have no modules )
    
    ext2fs_check_if_mount: No such file or directory wether /dev/hdi5 is mounted
    
    Filesystem couldn't be fixed
    what schould i do or where is the problem??
    make install not love

    Registered Linux user number 369245

  2. #2
    Linux Newbie
    Join Date
    Feb 2004
    Location
    India
    Posts
    132
    You have to be more precise, Like what are the kernel parameters in your bootloader. You display the grub.conf/lilo.conf and /etc/fstab
    You are the one Linux!

  3. #3
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    confirm that you are loading the files you think you are.

    Have you created a /boot partition and if so are you definately pointing at it in Grub/Lilo.

    Also are you certain that you did a 'make modules_install' (I think that you still need this with 2.6).

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •