Find the answer to your Linux question:
Results 1 to 6 of 6
hey hey everyone!!! im at a lan party, and so i could play most of the games i partitioned off a 20gb sector, and installed xp pro (belive me, im ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18

    lan party


    hey hey everyone!!!

    im at a lan party, and so i could play most of the games i partitioned off a 20gb sector, and installed xp pro (belive me, im disgusted as well).... well the problem lies in the fact that MS win overwrote my master boot record, and now i can boot only to windows.... i tired to use the ms boot loader.... i did so by doing this

    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOW S
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Micro soft Windows XP Professional" /fastdetect
    multi(0)disk(0)rdisk(0)partition(1)\Linux="linux-Debian" /fastdetect

    the last line is improvised by me... i assumed it was in partition one (which it is... but this didnt work, the boot loader then spit a "dll not found" error at me....... i was hoping micro****** would be nice enough to at least provide unbiased software, but i have not been able to figure it out.

    my second try was to boot to a rescue disk (linux, damn small linux to be more precise (a knoppix spinoff, nicely done)).... but when i tried to run lilo, it said "please edit lilo.conf", which i then proceded to do... i assumed the problem was that the file was on the cd, so i removed it and re-wrote it into the ram...... again no luck.....

    as you can see, i like to try things on my own before i call for help, and i would greatly apreciate if one of you could give me a hand in my problem..... thanks in advance, im just hoping i can get out of the MS problem before i leave the lan party tomorow.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    If you can find any iso images for booting into linux, you can do that. There should be some on the ftp site for your distro.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Linux User
    Join Date
    Jun 2003
    Location
    Calgary, AB CANADA
    Posts
    496
    Might be worth grabbing an boot floppy from here:

    http://www.yolinux.com/TUTORIALS/Lin...dBootDisk.html
    \"Everything should be made as simple as possible, but not simpler.\"
    Albert Einstein

  4. #4
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    well, we gave up and jsut went into "format mode" but it didnt seem to get the boot sector out, so now weve got a "failed to load os" error..... were trying some more stuff.... will post how it goes, and thanks for the help

  5. #5
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    If you have the distro cd (or some other guy at the computer party) you can use that to boot off the cdrom. When you have booted, just run /sbin/lilo and everything will be fine again

    Good luck

  6. #6
    Just Joined!
    Join Date
    Mar 2004
    Posts
    18
    wow, that one took me a while to figure out.. my rescue cd is knoppix, a live cd linux... so i had to specify that the lilo.config i would be using was on the mounted drive instead of the ramdisk. but still no luck... since this problem i have used an older version of my linux, it seems to work fine... i must have been the original cd i was using

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •