Find the answer to your Linux question:
Results 1 to 2 of 2
Hello everybody, I'll try to get rapidly to the point: running win2000 on my old IBM PC340 (p133, 48MB ram) is really a pain, so I decided to switch to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    Exclamation Help: GRUB won't load Linux partition!!


    Hello everybody,
    I'll try to get rapidly to the point: running win2000 on my old IBM PC340 (p133, 48MB ram) is really a pain, so I decided to switch to linux, and I chose one of the lightest (but full of apps) distros I could find, "Feathelinux".
    I have 2 HDs, one completely filled by win2000, the other formatted into 3 partitions: 1 for both windows/linux (containing my documents, mainly), one for Flinux and a swap one for Flinux itself (the last two formatted during installation of Flin).
    I won't bugger you with the details of how I managed to boot its live iso's content through "damn small linux"'s bootdisk ('cause featherlinux's official one won't work), and finally installed it on its fresh partition on my second hd drive (linux labeled it HDC2, search me why....I believe my 2nd HD is HDC, dunno why....).
    Perfect!....But the final step of Flin installation, the most important one (INSTALLATION OF LILO) fails everytime I do it!
    So basically I install Flin, but I can't boot it!
    I beg you, please, HELP me....I tried installing GRUB bootloader into the first HD's MBR (no probs, since I configured it to run my win2k os, from which I'm writing), then adding these lines to boot Flin from its linux partion:

    "title FeatherLinux
    kernel (hd1,2)/boot/vmlinuz root=/dev/hdc2 pci=off
    initrd (hd1,2)/linboot.bin",

    (Note: the pci=off option it's the only one that makes me boot the Flin image, otherwise the kernel panics, again search me why....)

    yet GRUB tells me
    "ERROR 19: cannot mount selected partition"!!

    Now, I don't know if I did input the right kernel and initrd files....yet from what I understood, GRUB cannot read the partition itself and its content....I even tried sbmngr, without success: it doesn't read linux partition!
    Please, help....how can I solve this situation? And, am I inputing the right kernel/initrd files?

    Tw@in 28

  2. #2
    Just Joined!
    Join Date
    Aug 2006
    Posts
    2

    Exclamation An update....yet still more problems!!

    Ok, I found out the right number of partition to specify to GRUB. The correct line was:

    "kernel (hd1,1)/ (name of kernel) root=/dev/hdc2"

    yet, damndamndamn, I DON'T KNOW WHAT IS THE KERNEL FILE I SHOULD BOOT....

    Inputing:

    "kernel (hd1,1)/vmlinuz etc...."

    Grub answers

    "(linux=bzimage, setup=0x1400,size0xf94da)"

    then

    "Error 29: unrecognized command"

    Please, help: what command should I give to finally load Featherlinux? (being a knoppix derivate, I'm meanwhile trying finding Knoppix lines that should adapt....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •