Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
I recently installed Redhat 8.0 and the install went fine but when i try to boot it goes thru the startup lines and then it just sits at "welcome to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Feb 2003
    Location
    PA, USA
    Posts
    13

    boot problem


    I recently installed Redhat 8.0 and the install went fine but when i try to boot it goes thru the startup lines and then it just sits at
    "welcome to redhat linux press i to enter interactive startup"
    "Mounting proc filesystem [ok]"
    "unmounting initrd: [ok]"
    "configuring kernel parameters [ok]"

    and then it just sits there. what can i do for this?

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    We had a problem very similar to this one about a month ago. At that time it seemed to be a hardware problem. It was solved by unchecking the "Plug 'n' Play OS" option in the BIOS. Could you try that?

  3. #3
    Just Joined!
    Join Date
    Feb 2003
    Location
    PA, USA
    Posts
    13
    I tried it and it still does the same thing???

  4. #4
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    While installing RedHat, did you use any strange options while configuring your clock settings?
    Also, what boot loader did you install? (GRUB or LILO)

  5. #5
    Just Joined!
    Join Date
    Feb 2003
    Location
    PA, USA
    Posts
    13
    nope no strange settings and i used grub.

  6. #6
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    OK, then, you seem to leave me with no other choice than this (I just hope that RedHat's initrd won't interfere):

    1. Boot up your computer, select the line in GRUB that should boot Linux, but don't boot it.
    2. Instead, press the 'e' key to enter edit mode. Go to the line that begins with "kernel", edit it, and add " init=/bin/sh" (don't ignore the space before init) to the end of that line. The keys necessary to do that are explained by GRUB.
    3. Go ahead and boot.
    4. When the system is ready for input, enter these commands (end each command with ENTER). If any command returns an error, abort and report back here.

    Code:
    export PATH=/bin:/sbin:/usr/bin
    mount -n -o remount,rw /
    cp /etc/rc.d/rc.sysinit /tmp/rc.bkup
    sed 's/^\&#40;.*hwclock\&#41;/#\1/' </tmp/rc.bkup >/etc/rc.d/rc.sysinit
    mount -n -o remount,ro /
    sync
    reboot -fw
    Then try again to boot normally, and see if it helps.

  7. #7
    Just Joined!
    Join Date
    Feb 2003
    Location
    PA, USA
    Posts
    13
    the init=/bin/sh does not even seem to be saved after i enter it. it most certainly does not do anything during the boot after i restart it. or maybe i am not saving the changes properly

  8. #8
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    No, it's not supposed to be saved. You should go on and boot from the edit screen, not reboot your system.

  9. #9
    Just Joined!
    Join Date
    Feb 2003
    Location
    PA, USA
    Posts
    13
    ok that time it worked but i got this error before i could even enter any of that code.

    mount: error 2 mounting ext3
    pivotroot: pivot_root (/sysroot,/sysroot/initrd failed: 2
    umount/ initrd /proc failed: 2
    kernel panic! No init found. try passing init=option to kernel


    after that it wouldnt let me do anything

  10. #10
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Yeah, I almost guessed that that stupid initrd that RedHat has would do that. What partition did you put the root partition on?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •