Find the answer to your Linux question:
Results 1 to 4 of 4
hello everybody, I have this problem, When I tried to mount the miniroot.gz, i am always have this error: ioctl: LOOP_SET_FD: Invalid argument. I unzip the file firt, and then ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7

    mount problems


    hello everybody,

    I have this problem,

    When I tried to mount the miniroot.gz, i am always have this error:

    ioctl: LOOP_SET_FD: Invalid argument.

    I unzip the file firt, and then I tried to mount it.

    here is what i did:

    gunzip filename.gz

    mount -o loop filename /mount_directory

    any ideas?

  2. #2
    Linux User
    Join Date
    Feb 2006
    Posts
    484
    check the type of the unpacked file
    code:
    file unpacked_file_name

    you only can mount iso files with loop

  3. #3
    Linux Newbie jpalfree's Avatar
    Join Date
    Jul 2005
    Location
    Montreal, CA
    Posts
    198
    I'm pretty sure you can mount more than just iso9660 with loop...
    I am able to mount initrds with loop and they were formatted as ext2/ext3.

    you could try specifying the filesystem type with -t
    as iwanabeguru said, you can use
    Code:
    file filename
    to check the type of the file.
    Avatar from xkcd.com, a hilarious computer related webcomic.

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Sep 2006
    Posts
    7
    Thank you for reply.

    I finally mount the file, and I know i just can mount with -o loop the iso images, but the file, in this case is the miniroot.gz, I unziped, and then mount the file without the gz extension.

    To be able to do this, I had to install my kernel-headers and my kernel-sources.

    thank you

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •