Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
my cousin told me about a software called partition manager. (Ranish partition manager- http://www.ranish.com/part/ ) . It works at quiet low level, so it can see evrything. It needs to ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined!
    Join Date
    Mar 2004
    Location
    chicago, IL, USA
    Posts
    8

    my cousin told me about a software called partition manager. (Ranish partition manager- http://www.ranish.com/part/ ) . It works at quiet low level, so it can see evrything.

    It needs to be copied on a bootable floppy. I used it and it showed me my primary partition with red color and the decription says "address out of range". So I think this s/w should be able to fix it.

    But for now my system is working fine with 2gb hard drive as master and 40gb as slave and there are few months left for my graduation. So I don't want to try anything at this moment.

    erkje, if you want to try it then you can get it from the site I mentioned above or just google for 'partition manager', its the first in the search results.

  2. #12
    Just Joined!
    Join Date
    Mar 2004
    Posts
    2

    CHS/LBA...

    I had some (much smaller) problems with my Laptop too (which doesn't have a floppydriver). I installed Fedora with grub as bootloader. The next morning I got a bash-like screen:
    • grub>

    After some short research I found out I had to type this:
    • rootnoverify (hd0,0)

      chainloader +1
      boot

    Very annoying to type that everytime I want to start windows. To solve this, I tried to recover the computer with the magnificent Acer-recovery CD.
    The first time it tried to check my HDD for errors and found for EVERY partition a wrong CHS value.
    "The LBA and CHS values are not equal. I have found out that the LBA is the correct one. Shall I repair the CHS value?"
    (or something like that)
    So, it wanted to repair them. 7 reparations later, I had to restart and was able to do the recovery.

    Still, I got the annoying grub> bootloader. Next I tried the XPrecovery console and executed (with great fear) the fixmbr...
    IT WORKED! The grub bootloader had gone, definitive.

    But my problem before (read my first post), is still not fixed. That friend of mine has a real computer with a floppydrive. I was wondering which application could repair the CHS values of the partitions. Maybe Norton Utilities?

    And that would probably also be the solution for you, jimmy.

  3. #13
    Just Joined!
    Join Date
    Mar 2004
    Posts
    1

    I had same problems, possible solution

    I had the same issues as the original poster. After the linux install, i could only boot to linux, not to windows. After trying to fix the problem, i ended up fubar'ing the MBR, and couldn't boot into anything. Here's what I did to resolve it (some / most of the steps might have done nothing towards solving the issue, but including just in case).

    1) downloaded a windows 98 SE boot disk from www.bootdisk.com.

    2) booted up with boot disk, used fdisk to delete all existing partitions, then did the fdisk /mbr to remove the MBR settings.

    3) downloaded / installed latest bios for MB (shuttle an35n )
    after updating bios, make sure that hard drive is set to LBA
    in my bios, i had to change the type from auto to LBA, as it kept
    switching to CHS.

    4) Reinstalled Windows XP, created a 20 Gig partition for XP (NTFS) - this is the first partition on the HD.

    5) also created a fat32 partition (20G) using windows xp installer.

    6) left the rest of HD (40G) unpartitioned

    7) finished installing XP (made sure it would boot at this point, and it would)

    8) install linux - i am using mandrake 10.0 - no special options, except custom partitioning - set up 3 add'l partitions; using the empty 40G; for linux using their auto-allocate option (I am a linux noob, so figured i would go with the default).

    9) I am using grub as my bootloader, using their default commands to load windows & linux.

    10) after linux install, on reboot, verify that the drive is LBA in bios, as changes to the MBR seem to affect how the bios sees the drive (-> pure speculation).

    11) i can now boot into both OSes with no difficulties (now configuring Linux and updating the drivers, etc., is another story entirely)


    I apologize if this is a little verbose, but I wish I had found this solution myself after trying to figure out these issues over quite a few days, so hopefully this will help someone out with the same problems. The bios update is probably not necessary in most cases - but the CHS / LBA issue is key , as with the drive in CHS mode, you will get the Error loading OS message.

  4. #14
    Just Joined!
    Join Date
    Apr 2004
    Posts
    7
    My Fedora Core 1 install crashed as it was formatting my Linux partitions with ext3.
    When I rebooted, my BIOS did not see either of my two hard drives (one should not have even been touched by the install).
    I tried fdisk /mbr from a floppy, but it said "no fixed disks found". I need to recover my ntfs/WinXP partition and my second FAT32 hard drive.

  5. #15
    Linux Newbie
    Join Date
    Apr 2004
    Location
    Looe, Cornwall UK
    Posts
    152

    re:

    valen1260, you said that your bios doesn't see the hdds, try swapping the jumpers on them, put the one that shouldn't have been touched onto primary master and unplug the other one from the mainboard, if your bios finds the hdd then try the same with the other one, if its not found then contact your hdd's manufacture to see if they can help, then try the same with the other one, if both are found when individualy connected, then reconnect them and see if they are found, if they are, pray to god thanking him for saving the life of your pc and reassemble it, if they aren't then contact their maker(s) and see if they can help.
    Cry out for freedom! Cry out for Linux!

  6. #16
    Just Joined!
    Join Date
    Apr 2004
    Posts
    7
    To clarify, it wasn't a new system. Things had worked well until the FC install crashed.
    At any rate, I booted with Knoppix, and when I restarted, my harddrives were back.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •