Find the answer to your Linux question:
Results 1 to 7 of 7
Fresh install of Debian Etch, default Desktop package with gnome. Everything seems to work fine except my screen resolution is stuck at 640x480 and my monitor supports up to 1280x1024 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Sep 2006
    Posts
    10

    xorg screen res problems, tried dpkg-reconfigure


    Fresh install of Debian Etch, default Desktop package with gnome.
    Everything seems to work fine except my screen resolution is stuck at 640x480 and my monitor supports up to 1280x1024 @ 60 Hz (eView 17f2).
    I tried dpkg-reconfigure xserver-xorg but it doesn't solve anything. Here is my xorg.conf file;

    # /etc/X11/xorg.conf (xorg X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
    # (Type "man /etc/X11/xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    # sudo dpkg-reconfigure -phigh xserver-xorg

    Section "Files"
    FontPath "/usr/share/fonts/X11/misc"
    FontPath "/usr/X11R6/lib/X11/fonts/misc"
    FontPath "/usr/share/fonts/X11/cyrillic"
    FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
    FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
    FontPath "/usr/share/fonts/X11/Type1"
    FontPath "/usr/X11R6/lib/X11/fonts/Type1"
    FontPath "/usr/share/fonts/X11/100dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
    FontPath "/usr/share/fonts/X11/75dpi"
    FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
    # path to defoma fonts
    FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    EndSection

    Section "Module"
    Load "i2c"
    Load "bitmap"
    Load "ddc"
    Load "dri"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "type1"
    Load "vbe"
    EndSection

    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "CoreKeyboard"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc104"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    Option "Device" "/dev/input/mice"
    Option "Protocol" "ExplorerPS/2"
    Option "Emulate3Buttons" "true"
    EndSection

    Section "Device"
    Identifier "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Driver "nv"
    BusID "PCI:2:0:0"
    EndSection

    Section "Monitor"
    Identifier "eView 17f2"
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Monitor "eView 17f2"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1024x768" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1024x768" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1024x768" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1024x768" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1024x768" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1024x768" "800x600" "720x400" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Generic Keyboard"
    InputDevice "Configured Mouse"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection
    edit: yes I have tried manually adding in my desired screen res, no luck either

  2. #2
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    What happened when adding manually the res? Did you add it to the correct color depth?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  3. #3
    Just Joined!
    Join Date
    Sep 2006
    Posts
    10
    Nothing happened at all, yes I added it to the correct color depth.

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Did you add it First?
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  6. #5
    Just Joined!
    Join Date
    Sep 2006
    Posts
    10
    yes, i added it first.

  7. #6
    Linux Guru Juan Pablo's Avatar
    Join Date
    Mar 2006
    Location
    /home/south_america/ecuador/quito
    Posts
    2,064
    Well, I'm out of options. The way you described have always worked for me a for a lot of people in the forum.

    This is really the only way to change the resolution in Linux, but maybe this is a bug
    Put your hand in an oven for a minute and it will be like an hour, sit beside a beautiful woman for an hour and it will be like a minute, that is relativity. --Albert Einstein
    Linux User #425940

    Don't PM me with questions, instead post in the forums

  8. #7
    Just Joined!
    Join Date
    Oct 2006
    Posts
    1

    FInally got mine to work

    I was having the same problem as you were on my fresh install using the same basic video card (Geforce 4 MX)

    I copied over my working config from my other box and it works fine. I am betting that this has to do with they Horz and Vert Refresh rate. You probably don't want to copy mine as your monitor is likely different.

    ****Didn't work 640x480 only

    Section "Device"
    Identifier "NVIDIA Corporation NV18 [GeForce4 MX - nForce GPU]"
    Driver "nv"
    BusID "PCI:2:0:0"
    EndSection

    Section "Monitor"
    Identifier "Generic Monitor"
    Option "DPMS"
    EndSection


    *** works swimingly.

    Section "Monitor"
    Identifier "Acer AL1912"
    HorizSync 24-80
    VertRefresh 49-75
    Option "DPMS"
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "Acer AL1912"
    DefaultDepth 24
    SubSection "Display"


    Good Luck

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •