Find the answer to your Linux question:
Page 2 of 2 FirstFirst 1 2
Results 11 to 17 of 17
Install also only seems to detect one of the processors... The motherboard is a MSI K7D Master (MS-6501), which has 2 AMD Athlon(tm) 2000+ MP processors in it. If I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #11
    Just Joined! phich65's Avatar
    Join Date
    Sep 2006
    Location
    Cambridge
    Posts
    8

    The plan was... (pt2)


    Install also only seems to detect one of the processors...
    The motherboard is a MSI K7D Master (MS-6501),
    which has 2 AMD Athlon(tm) 2000+ MP processors in it.

    If I select 'Change' option, there's no option to add a second processor.

    Is there some installation command line switch like '-SMP' that I forgot?

    fish

  2. #12
    Just Joined! phich65's Avatar
    Join Date
    Sep 2006
    Location
    Cambridge
    Posts
    8
    Quote Originally Posted by devils_casper
    i never heard that Linux can be installed on FAT32 partition....

    SuSe default format is 'reiserfs'. select that only. why dont you leave it as unformatted/free space. SuSe installer will take care of formatting and partitioning.
    Err... okay, just going by what BigPhish had said. I hadn't realised that /home counted as an install partition (I guess)

    I think his idea was to have this as a partition which both OSes could see and use as a file transfer area.

    I could split it in half and mount half as /home (20GB rieserFS) and half as /transfer (20GB FAT32)

    Or is that just stupid(tm)

    fish

  3. #13
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    its a good idea. split it into two. FAT32 for data sharing and rest for /home.




    casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #14
    Linux Newbie
    Join Date
    Apr 2005
    Location
    CT --> PA
    Posts
    170

    Suse is weird then!

    Hmmm SuSe won't let you mount /home on a fat32 partition? Both Slackware & Debian do, and have done for QUITE some time. I think it's more of a built in paranoia thing to the suse install scheme (which i have admittedly never used) than an impossibility. That's too bad. I'll bet that if you were to set it up and then change the mount points to /home on that FAT32 partition, it would work...bummer.

    Well, all in all mount it as /mydocs, sym-link it to /home/mydocs, and then make it your "My Documents" directory in the WinXP install and you will only have to traverse 1 click (depending on which GUI you use, and which ruleset - fwiw) to find stuff in either OS.

    I would be willing to bet that after you get this all up and running that you can mount /home as a fat32 partition and make it work just fine...hell, if i was you (and i would not do this unless you want to reinstall it all again when it borks up) i would make a joke partition of like 10 megs after my swapspace, mount that as /home during the install, do all the nicey-nicey things to make the install finish, go back after it reboots and you are running...remount the fat32 partition as /home (after moving all the stuff that suse might stuff in there to it), kill the joke partition, make it more swap-space and go on living life like it should be lived...with /home on a fat32 (j/k about that)
    Chicks dig giant mechanized war machines

  6. #15
    Just Joined! phich65's Avatar
    Join Date
    Sep 2006
    Location
    Cambridge
    Posts
    8

    The plan was... (pt3)

    Nevermind BigPhish, we got a working work-around...

    LOL, only problem now is I can no longer boot into XP...

    It's there as an option in the GRUB menu, but when I select it all I get is a DOS type screen with 2 lines of text

    chainloader (hd1,0)+1
    h.¬

    (yes i get a smiley face symbol at the end of the 2nd line)

    So far I've tried using the windows repair console to recover this, but FIXMBR doesn't appear to have changed anything.
    I can log into the windows installation in the repair console after booting from an XP CD, but it comes up as C:\windows - NOT G:\windows as I was half expecting...

    Now there's every chance that creating a new FAT32 partition has caused WinXP to allocate new drive letters...

    Guess I'm stuffed and will have to re-install XP... or I may try swapping the XP disk back to being on the Primary Master interface, and put the Linux drive onto the Secondary Master the re-install grub to see if that fixes it.

    My interface order is

    Pri Master - HDD1 - 80G Linux (/dev/hda1 to /hda6)
    Pri Slave - DVD
    Sec Master - HDD2 - 40G WinXP (/dev/hdc1)
    Sec Slave - empty
    ATA1 Master - HDD3 - 160GB WinXP & Linux (/dev/hde1 to /hde3)
    ATA1 Slave - empty
    ATA2 Master - CD-ROM
    ATA2 Slave - empty

    Do I have to use the 'map' function in GRUB to keep WinXP happy - even though previously XP would boot by setting my BIOS to boot from that HDD first (nice BIOS) - this was before I added partitions during the SuSE install

    Anyway if this helps here's the GRUB files...

    /boot/grub/device.map

    (fd0) /dev/fd0
    (hd2) /dev/hde
    (hd1) /dev/hdc
    (hd0) /dev/hda


    /boot/grub/menu.lst

    title SuSE Linux 10.1
    root (hd0,0)

    [etc... i'm not typing it all out]

    title Windows
    chainloader (hd1,0)+1


    /etc/grub.conf

    setup -stage2=/boot/grub/stage2 (hd0,0) (hd0,0)
    setup -stage2=/boot/grub/stage2 (hd0) (hd0,0)
    quit


    Off to try using the 'map' command

    fish

  7. #16
    Linux Newbie
    Join Date
    Apr 2005
    Location
    CT --> PA
    Posts
    170
    Quote Originally Posted by phich65
    Nevermind BigPhish, we got a working work-around...

    LOL, only problem now is I can no longer boot into XP...

    It's there as an option in the GRUB menu, but when I select it all I get is a DOS type screen with 2 lines of text

    chainloader (hd1,0)+1
    h.

    (yes i get a smiley face symbol at the end of the 2nd line)

    So far I've tried using the windows repair console to recover this, but FIXMBR doesn't appear to have changed anything.
    I can log into the windows installation in the repair console after booting from an XP CD, but it comes up as C:\windows - NOT G:\windows as I was half expecting...
    The Recovery Console always assumes that the installed partition is set up for C: no matter what other OSes may think, see, or be set up for. That part is normal.

    Quote Originally Posted by phich65
    Now there's every chance that creating a new FAT32 partition has caused WinXP to allocate new drive letters...

    Guess I'm stuffed and will have to re-install XP... or I may try swapping the XP disk back to being on the Primary Master interface, and put the Linux drive onto the Secondary Master the re-install grub to see if that fixes it.
    Yes, it will create new drive letters, but will almost always place them AFTER the system root "C:", so it won't affect your boot.

    See, this was EXACTLY the reason i avoid moving XP to secondary HD's to install. I've had some weird problems with FIXMBR on secondary HD's as they never seem to write a perfectly usable master boot record, however, when i use it on disc 0,0 it works just dandy. If your BIOS supported the booting from different discs option, i would have left XP on disk0 and put Suse on disk1 and then told it to boot from disk1. Move the XP drive back to disk0, recovery console the hell out of it, and then LEAVE IT THERE. Then i would install SuSe on the disk1 space, install grub there, let it find all the OS'es and then tell your BIOS to boot to disk1. tried and true.

    Apparently XP NEEDS to be on the primary partition of disk 0 to work, stupid m-soft.



    oooh, oooh look what i found!.
    http://www.oculon.org/hijinx/linux/grub.htm

    Go there, look at the section about booting with Windows on the SECOND DRIVE. There is your solution.
    Chicks dig giant mechanized war machines

  8. #17
    Just Joined! phich65's Avatar
    Join Date
    Sep 2006
    Location
    Cambridge
    Posts
    8
    Quote Originally Posted by TheBigPhish
    oooh, oooh look what i found!.
    http://www.oculon.org/hijinx/linux/grub.htm

    Go there, look at the section about booting with Windows on the SECOND DRIVE. There is your solution.
    I'd found something very similar over on Unofficial SuSEFAQ
    just the order of the commands are slightly different

    title Windows XP
    map (hd0) (hd1)
    map (hd1) (hd0)
    root (hd1,0)
    chainloader+1
    makeactive


    OR

    title = Windows 98
    root = (hd1,0)
    map (hd0) (hd1)
    map (hd1) (hd0)
    makeactive
    chainloader +1

    I've tried the top version, and it doesn't appear to work... will check for typos later.

    Get the feeling I need to swap Linux and WinXP hard drives around to prove WinXP is still bootable...or at least disconnect the Linux drive.

    fish

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •