Find the answer to your Linux question:
Results 1 to 6 of 6
Im trying to install fedora core 1 onto my flatmates laptop, but it locks completely on the first setup screen ("check install cd?") i cant move the selected box or ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766

    Fedora install freezes on Presario 2100 laptop


    Im trying to install fedora core 1 onto my flatmates laptop, but it locks completely on the first setup screen ("check install cd?") i cant move the selected box or press ctrl+alt+f1-4.

    i have tried "linux nofb pcmcia=off acpi=off noprobe skipddc" but it still locks at the same place, iits not the cd check that causes it to freeze either because once i managed to give it boot options so it went straight to the language selection thing, but that was frozen as well.

    I have also tried text install and using an external kdb (my first guess was messed keyboard thing) but it hasnt helped. I have removed all usb/pcmcia devices from it as well.

    Mandrake 9.0 looked like it was goign to install fine, but couldnt resize ntfs without killign it so i had to stop. (im dloading partition magic now)

    I would like fedora installed since its newer and its the same thign we use for comp sci labs at uni.

    Thanks

  2. #2
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    compaq evo1015v

    I have a compaq evo 1015v I installed fedora using the following boot options:
    inux nomce ide=nodma pci=off

    the nomce = prevents an mce error (which I never experienced)
    ide=nodma stops the harddrive from responding
    pci=off seemed to be the only way to get the install procedure to accept that there is a cdrom in the machine

    once installed you can play with the options you need to send the kernel via the grub conf file. Although it's still a bit buggy. It doesn't like the dynamic nature of the nic for starters. sometimes it's plugged in and then it detects it and other times there's no cable in and fedora thinks I've removed the card.

    check out this link: http://tooleweb.homelinux.com/EvoN1015v/

    also check out this one - its for your laptop
    http://lisonbee.freeshell.org/linux/...ario_2100.html

    good luck.

    Once you get a basic install - then the people on this forum seem to be able to help get everything else working - one step at a time.
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  3. #3
    Just Joined!
    Join Date
    Mar 2004
    Posts
    2
    You need to press F2 when it boots to get to the bios setting and turn off legacy USB support

  4. $spacer_open
    $spacer_close
  5. #4
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    why

    I think that option is called something like usb support for DOS on my BIOS.

    what does that do?
    No trees were harmed during the creation of this message. Its made from a blend of elephant tusk and dolphin meat.

  6. #5
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    The bios is not an issue, i ahev checked it multiple times, and it seems to only have abotu 3 settings in it. (ie theres just no options anywhere???) it didnt have a p&p option and i dont remember a thign for usb of any kind, also there were no options to turn off certain devices.

    i will give the nomce nodma pci=off line atry and see what that does tomorrow. (its 2am here now) once i get it installed i should be able to get it working, Ive spent long enuf fixing other peoples problems i should be able to fix a comp sittign in front of me.

  7. #6
    Just Joined!
    Join Date
    Apr 2004
    Location
    Rockford, IL
    Posts
    1

    Same problem on HP pavillion ze5270

    I had the same problem with the install of Fedora... RH9 installed fine the first time... I tried that tag with "linux nomce ide=nodma pci=off" and it worked except i had no mouse driver... well I did but it was incredibly erratic... But i did try to disable the legacy USB in the bios and it still froze.. so I tried several other tags.... and (I KNOW THIS ISN'T A VALID TAG BUT...) with the bios legacy usb disabled... and boot pram for "linux freeze-donteven****ingthinkaboutit" IT WORKED!! I don't know why... but it's working perfect... Installed and updated...not a single hitch... even works better than RHEL WS because with WS it didn't recognize my soundcard.... TRY IT IF YOU'RE STILL HAVING TROUBLE!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •