Find the answer to your Linux question:
Results 1 to 10 of 10
Eveyrtime i try and install it wont load GUI, i can get in command line sometimes, but i have no idea what to do from that point. Anyhelp is appreciated, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Mar 2004
    Location
    Stockton, CA
    Posts
    7

    RH9 install with nvidia fx 5200


    Eveyrtime i try and install it wont load GUI, i can get in command line sometimes, but i have no idea what to do from that point. Anyhelp is appreciated, as im dual booting with Windows for my gaming needs. I need my Video card !!!!

    Please help

    Thanks

    Erik

  2. #2
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Okies some extra info is needed here.

    I get the feeling your X is failing.
    Could you clean the XFree86.log located in the /var/log
    Make sure to remove it first, then try to boot X with startx and then post that logfile.

    One of the other this you could try is this:

    Use wget to download the Nvidia drivers.
    If you are unable to download it from the Nividia site use this link:
    Code:
    wget http://www.opnosforatou.com/files/NVIDIA-Linux-x86-1.0-5336-pkg1.run
    Note: This link will only be valid for 1 week.
    Then run this file with: [Be sure to run it as root]
    Code:
    sh NVIDIA-Linux-x86-1.0-5336-pkg1.run
    This will create and install the NVidia drivers.
    Now we need to update your XFree86 configuration.
    Go to: /etc/X11 and edit the file: XF86Config.
    Search for: Section "Device"
    and replace the driver name to nvidia
    Search for: Section "Module"
    and make sure you have the Load "GLX"
    Example:
    Code:
    Section "Module"
            Load  "dbe"
            Load  "extmod"
            Load  "fbdevhw"
            Load  "glx"
            Load  "record"
            Load  "freetype"
            Load  "type1"
    EndSection
    Remove any of the following lines:
    Code:
            Load  "dri"
            Load  "GLcore"
    This should do the trick..

    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  3. #3
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    Opnosforatou,
    nicely answered, have you thought of writing a how to and submitting it to our moderators for inclusion in the tutorial section?


    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  4. $spacer_open
    $spacer_close
  5. #4
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Quote Originally Posted by Nerderello
    Opnosforatou,
    nicely answered, have you thought of writing a how to and submitting it to our moderators for inclusion in the tutorial section?


    have fun

    Nerderello

    errr. nopes...
    Haven't had time to read the faq/howto on that one
    I'll write a little HowTo on it and send it to one of the moderators and see if he/she will post it.
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  6. #5
    Just Joined!
    Join Date
    Mar 2004
    Posts
    34

    a possible minor addition

    unfortunately, i had this exact problem, although i didnt have Opnosforatou's answer to help me solve it.

    one thing of note, and its something that stumped me for two days solid, is a bios setting i had to change to complete the solution.

    i followed almost the exact same procedure as described by Opnosforatou but to no avail, the driver module continually failed to initialise. after quite a lot of detective work (with much help from google), i had to change a setting in my bios

    the two things i had to change were:

    "plug and play os" change from "yes" to "no"

    and

    "assign irq to pci vga" change from "no" to "yes"

    after that, the nvidia drivers worked perfectly.

    another point worth noting, is that i managed to get the graphics working, without the use of the downloaded nvidia drivers. if you set the driver to "nv" in the x config file, then the card will work, albiet with limited effect (800x600 is the best res you can get, and dont change from the default, or it tends to fail), but its enough to start X to get through redhats 'firstboot' thing, and onto the desktop. whilst i doubt its a permanent solution, its enough to get past first boot so you can log in and reach the point where you can edit the x configs.

    in order to actually change the driver to "nv" to get the machine to the point i could log in, i took these steps.

    1. install redhat in text mode

    2. after installation, wait for the system to try to start firstboot and wait for the screen to go onto its blank standby thing (i dont know what its called, but it seems to be like when the screen is turned off on powersaving mode)

    3. put in the redhat cd 1, then press ctrl+alt+del

    4. watch the pretty scroll as things shut down.

    5. when the system boots, on the "install redhat" screen, use the command "linux rescue" to start up in rescue mode

    6. when asked if you want to mount the drive, choose to mount it.

    7. when you get to the command prompt, use this command "chroot /etc/sysimage" (the installer tells you the command)

    8. at this point, i did almost exactly what Opnosforatou put in his post, and it was all plain sailing from then on.

    im afraid im not that experience in linux, so thats about the best description i can give, although im sure one of the more experienced people on this forum can elaborate on anything i may have fudged.

    hope this helps, i know this can be a very frustrating problem.

  7. #6
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    This is a tricky way to do get it working.

    I allways set my bios setting on Plug and Play aware O.S. to No
    "assign irq to pci vga" change from "no" to "yes"
    I'm not sure about this one, since the graphics card we're talking about is AGP not PCI.
    I'll check my bios when I get home and see what I've set it on.
    But I think It's still No.
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  8. #7
    Just Joined!
    Join Date
    Mar 2004
    Posts
    34

    your right, but im not sure about the bios either.

    your right, it is a tricky way of getting it working, and it does seem long and involved, but at the time i didnt have the resourses of this board, and i kinda had to work it out as i went along. i included the method i used only as an alternative, in that i found it difficult to actually get to the command line to implement your solution. i guess it shows that this is my first linux installation

    as for the bios settings, i would be inclined to agree with you, it shouldnt make any difference as the card is a agp, not pci. in practice, however, my card wouldnt work properly with it set any other way. im not exactly sure why, but i have a feeling its something to do with my motherboard. the motherboard is an "elitegroup k7s5a pro".

    whilst actually installing the nvidia drivers, the sample X configuration file has a board id setting, and tells you that you can get the board id from the command 'lspci' that gives my card a bus id of 1:0:0. again my inexperience shows in that i dont actually know what this means, but im guessing (from the fact that its output appears to scan the pci busses) that for some reason my card appears as a pci device, and needs an irq.

    either way, although im not sure of why it works, i know it does work for my system, i would be interested to see how you have yours set (i assume your using a 5200 too?) even if only to find out if its a quirk of this board.

  9. #8
    Linux Enthusiast Opnosforatou's Avatar
    Join Date
    Dec 2003
    Location
    Vleuten, The Netherlands
    Posts
    552
    Here are my system specs:

    Motherboard: ASUS P4B800 Deluxe
    Video: ASUS V9950 Ultra
    Network: Onboard 3COM Gigabit Lan, luckaly the driver for linux was on the Asus CD
    Harddisks: 200GB Maxtor.

    That's it.. Ohh, and 11 Cooler fans to keep the working temp between 35Celsius and 40C....

    It might sound spoiled but all the systems i have are home made.
    All motherboards are Asus, incl all Videocards.
    All NIC's are 3Com.
    All HD's are Maxtor.
    ---[ MS09-99896 - Vulnerability in All MS Windows OS ; Using Windows Could Allow Remote Code Execution. ]---
    Hardware: Asus P4P800, 1GB, P4-3Ghz, Asus V9950, Maxtor ATA HD\'s, 3Com GBit lan, Audigy ZS Plat.

  10. #9
    Just Joined!
    Join Date
    Mar 2004
    Location
    Stockton, CA
    Posts
    7
    I tried installing from the command line, I accept the liscense agreement then it tells me this .

    " Unable to load the kernel module 'nvidia.o' It said i might be using the wrong kernel source. It also said to be sure to have the "kernel_source' rpm installed, since im new im totally lost.. I dont have the card installed now, im just using onboard video on my intel 865 board.

    Thx

    Erik

  11. #10
    Just Joined!
    Join Date
    Mar 2004
    Location
    Stockton, CA
    Posts
    7

    !

    I got it working!!!!!!!!!. All i did was go into redhat-config-xfree86 it had a generic nvidia Fx driver includied in rh9. i selected that, turned off my pc, disabled my on board video, installed the Fx5200 into the agp slot, booted up and no probllems.

    Thanks for everyones help

    Erik

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •