Find the answer to your Linux question:
Results 1 to 3 of 3
Anyone else have this problem. Got my linux Redhat 8 machine running as a pdc. The first time i joined the domain everything went ok. I rebooted and was able ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2003
    Location
    Overland Park KS USA
    Posts
    26

    SAMBA PDC AND XP CLIENT PROBLEMS


    Anyone else have this problem. Got my linux Redhat 8 machine running as a pdc. The first time i joined the domain everything went ok. I rebooted and was able to load my profile. However just to check things out i rebooted to make sure my profile was saved. When i rebooted i got this error "Windows cannot copy file \\orion\profiles\root\Cookies\index.dat to location C:\Documents and Settings\rootCookies\index.dat. Possible causes of this error include network problems and or insufficient security rights. If this problem persists, contact your network administrator." Does anybody have any idea what could cause this? Also when i first logged on it said that i didn't have administrator priviledges. How do i set my samba acounts so I have administrator privledges on my XP clients? Thanks in advance.

  2. #2
    Linux Guru
    Join Date
    Oct 2001
    Location
    Täby, Sweden
    Posts
    7,578
    Luckily, I have little use for Samba since I myself don't use Windows. I do on the other hand know that there is an option in per-share smb.conf called "profile acls" which might be of interest to you. Check it out in the manpage for smb.conf.
    About the administrator thing, I'm guessing that you're looking for the global smb.conf option "domain admin group", which will specify user names to be part of the "Domain Admin" group. I don't really know if that's the one, but I'd guess so.

  3. #3
    Linux User
    Join Date
    Jan 2003
    Location
    Cardiff, Wales
    Posts
    478

    Admin Group

    Samba / Linux does not have global groups in the way microsoft networks do. But samba can simulate this. What I did was:
    Created a group called admins on the linux box and added appropriate users to it (initially everyone ). Then added the following line to the Globals section of the smb.conf.
    Domain Admins = +admins

    and that sorted that problem.

    The roaming user profiles were a problem for me as well. I created a share on the pdc called profiles and set the options in the smb.conf to create a folder for profiles by username. Then I set the profiles folder to have everyone everything access with chmod. Think I turned on world access as well.

    Other option is to disable roaming profiles if you don't need them. That may well be simpler. This can be done from user manager in XP client or as an option in the smb.conf by setting the user profile path variable (I think thats "logon path") to nothing e.g. logon path = "". But haven't tried that myself.

    Cheers

    Kris

  4. $spacer_open
    $spacer_close

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •