Find the answer to your Linux question:
Results 1 to 6 of 6
ok, I'm running a stock RedHat 9 system. I found multiple documents on how to upgrade it to 2.6 I followed them very closely. I am having a Kernel Panic ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    3

    Kernal 2.6 and booting off RAID1


    ok, I'm running a stock RedHat 9 system. I found multiple documents on how to upgrade it to 2.6 I followed them very closely. I am having a Kernel Panic when it tries to boot. I have (2) 1.2 gig drives mirrored as the boot partition /dev/md0. I have the swap partition ad /dev/md1 I then have a large data partition on 2 other drives as /dev/md2. Kernel sees the md drives and creates the raids. I can see on the screen that it created md0. it also says that Personality 3 is not loaded. then it stops the raid? then it unbinds to the raid. then it says autorun done.


    Here's some of the output:
    mount: error 19 mounting ext3
    pivotroot: pivot_root (/sysroot,/sysroot/initrd) failed: 2
    umount /initrd/proc failed: 2
    freeint unused kernel memory 167k freed
    kernel panic: no init found. try passing init= option ot the kernel

    If I comment out the initrd file in grub.conf I get:
    the md stuff as usual
    right after that I get:
    EXT2-fs unable to read superblock
    isofs_fill_super: bread failed, dev=md0, iso_blocknum=16, block=32
    kernel panic: unable to mount foot fs on md0

    here's my grub.conf:
    default=0
    timeout=10
    splashimage=(hd0,0)/boot/grub/splash.xpm.gz
    title Red Hat Linux (2.4.20-8)
    root (hd0,0)
    kernel /boot/vmlinuz-2.4.20-8 ro root=/dev/md0
    initrd /boot/initrd-2.4.20-8.img

    title Red Hat Linux (2.6.4)
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.4 ro root=/dev/md0=/
    initrd /boot/initrd-2.6.4.img
    title Red Hat Linux (2.6.5)
    root (hd0,0)
    kernel /boot/vmlinuz-2.6.5 ro root=/dev/md0=/
    initrd /boot/initrd-2.6.5.img
    root@iowa:/www/derekslama.com/horde/turba/config>


    Any help or anything pointing me in a direction would be great! Thanks in advance.

    Derek

  2. #2
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    What partition type is /boot ? It cannot be FD(RaidAuto-detect) you cannot boot from a raided partition it has to be 83(Linux) and flaged bootable.

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    3
    hmmm, that's odd. the /boot folder is all on the one main / partition. I don't have a seperate partition for it. I was able to do this just fine on Red Hat 9. Is this not possible with kernel 2.6? If so I may have to redo my whole server to create a seperate partition for /boot? How big should it be? is there a way to resize my drives to make room for it?

    Derek

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    3
    I had to make my initrd on my own for some reason. the one that make install tried to do fails with this error:

    root@iowa:/data/backup/server/kernel/linux-2.6.5>make install
    make[1]: `arch/i386/kernel/asm-offsets.s' is up to date.
    CHK include/linux/compile.h
    Kernel: arch/i386/boot/bzImage is ready
    sh /data/backup/server/kernel/linux-2.6.5/arch/i386/boot/install.sh 2.6.5 arch/i386/boot/bzImage System.map ""
    No module raid0 found for kernel 2.6.5
    mkinitrd failed
    make[1]: *** [install] Error 1
    make: *** [install] Error 2

    I had to make my own initrd by running:

    mkinitrd --omit-raid-modules /boot/initrd-2.6.5 2.6.5

    So maybe that has something to do with it?

    Derek

  6. #5
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2

    Ext3 modules

    Sorry if i'm stating something really obvious here - I'm pretty new to linux

    When I tried building a 2.6 kernel I remember reading something about making sure the ex3 modules are built into the kernel (not as modules) because of the /boot partition being ext3 (this might be redhat only)

    I only mention it because the error you have looks like the one mentioned in the guide with the above as the solution

  7. #6
    Linux Engineer Giro's Avatar
    Join Date
    Jul 2003
    Location
    England
    Posts
    1,219
    Yeh you should build all fs and ide stuff directly into the kernel.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •