Find the answer to your Linux question:
Results 1 to 4 of 4
This could be a confusing one (or possibly I'm easily confused) I have a P4 system with two hard drives. One is a standard ATA100 drive with a RedHat 9. ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2

    Problem with dual boot system - GRUB + Serial ATA


    This could be a confusing one (or possibly I'm easily confused)

    I have a P4 system with two hard drives. One is a standard ATA100 drive with a RedHat 9. The other is a Maxtor s-ata drive with Windoze XP. This is set in enhanced mode

    The detailed setup is:
    Channel 1 Master Fujitsu 40GB (Linux)
    Channel 1 Slave None
    Channel 2 Master DVD-RW
    Channel 2 Slave DVD Rom
    Channel 3 N/a Maxtor 120Gb sata (Windows XP)
    Channel 4 N/a None

    I know it looks weird. Something to do with enhanced mode in the BIOS, (I get messages from it about not having cables installed for ch 3+4 slaves)

    All that said and done, here is the problem:
    Linux only recognises this drive with libata installed
    GRUB does not recognise it at all.

    This means that at the moment I am switching boot priority in the bios to choose between installations. What I want to do is use the Windows boot loader to chain load grub. To do this I copied the boot sector from the linux drive (/dev/hda), saved it on the XP partition and added it to boot.ini.

    When I select the Linux option on the XP Boot menu all that appears is 'GRUB' in the top left corner of the screen. I'm guessing that this is because GRUB expects to find it's stage 2 image on the same drive stage 1 was loaded from. In this case, how do I tell grub to load it's image from the correct drive? (/dev/hda)

    Or is the problem loads more complicated? Is there a simple solution?

  2. #2
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6

    We're in the same ship

    Hi Squizzar, i read ur post and i thought that i m 2 suffering from the same problem, but in my case the scenario is different.

    I m also having two hard drives, but one of them is 512MB compact flash and the other is 30GB IDE hard disk.

    The 512MB CF is having redhat 9 installed and 30GB HDD is also having redhat 9.0 installed on it.

    The CF is primary master and IDE HDD is primary slave.

    What i want to do is, change the grub.conf file in 512MB CF so that it shows the boot option for partition on the 30GB HDD as well.

    As I m relatively new to linux, i m unable to understand the funda.

    If anybody could help, that will be gr8

  3. #3
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi knikhil271083 !

    Welcome to the LinuxFoums !!!

    boot up from CF and mount RedHat's /boot partition of IDE. copy 'title, root, kernel and initrd' ( first block ) from its grub.conf file ( its in mount_point/grub folder ) and paste in the /boot/grub/grub.conf file of CF. you must be logged in as 'root'.
    reboot...






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Dec 2006
    Posts
    6

    Thanx it worked fine

    Hi devils_casper,

    The solution provided by you worked fine.

    thanx for the help

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •