Ok, here's the story.

I had these partitions:
* Primary 69GB NTFS (Active)
* Extended Linux Parttiton Containing:
- 2.3GB Ext3
- 3.6GB Ext3
- 499MB Swap
I found a web page, (http://www.libranet.com/support/view...item=0307.html), which guided me to resize ntfs, making more room for the linux partitions to be resized.

So, I ran NTFSResize in linux (mandrake 10.0), after unmounting the NTFS partition. This process seemed to go smoothly, so i continued on to the repartitioning.

I opened up fdisk from the command line in Mandrake. My goal was to resize the NTFS partition to 61440MB. Up until this point, i had followed the instructions on the webpage which i pasted earlier. So i followed the steps for repartitioning exactly (or so i thought) aside from the different partition size.

But then, after i wrote the changes to the partition table, something went terribly wrong. My NTFS partition had become FAT16, and was only 36GB in size! When I tried to boot into windows, I got the error "NTLDR Cannot be found"

I determined that my problem for the wrong size was that i entered the cylinder number instead of the disk size (writing 61440 instead of 61440M in fdisk). This had made the size of the first partition 36GB instead of 61GB.

From this point, i started with the repartitioning instructions (at the website I pasted) from the beginning. Only this time, entering all of the settings correctly.

I then booted a system rescue cd (http://www.sysresccd.org), and enetered QTParted to see the partition info. I found that the size problem was fixed, but the filesystem type was still FAT16. And also when i mounted the drive, all of the filenames and folder names were corrupted, with irregular names such as "c.b?" or other names with strange characters. Although, when in Mandrake linux, DiskDrake reported that the filesystem is NTFS. And in Mandrake, I was not able to mount the drive (the error was "bad fs type, bad option, bad superblock on /dev/hda1, or too many mounted file systems")

What can i do now? Is there any way of recovering the data, or returning the partition to being bootable?

Any help greatly appreciated.