Find the answer to your Linux question:
Results 1 to 7 of 7
I am a new user and have been playing with Linux for several weeks. This has involved numerous re-installations and I'm slowly learning. The last time I re-installed Linux, I ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    10

    Booting Problems with fsck


    I am a new user and have been playing with Linux for several weeks. This has involved numerous re-installations and I'm slowly learning. The last time I re-installed Linux, I started getting an fsck on every boot up. This is the first installation on which this has happened. I cannot get rid of this and the check takes 3-5 minutes. Since I am rebooting many times a day during tests and switches to Windows XP this check is really irritating. I want to disable this check on every boot and re-installing my Linux did not work. Here are some of the specifics:

    Dual boot Ubuntu/Windows XP with Grub.
    Windows XP boots normally.
    fsck runs on every Ubuntu boot, appearing after the Ubuntu splash screen and going to a text-only screen.
    During the test, I get a message at one point that says "there are differences between boot sector and its backup". That doesn't stop the check or Ubuntu eventually loading.
    As I mentioned, I tried reinstalling Ubuntu but still get the fsck.

    Thanks for any help fixing this irritant.

    Dave

  2. #2
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    hi Need-help !! Welcome to the Forums !

    post the contents of /etc/fstab file.






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    10
    Below is the fstab. As you look at it, perhaps you can tell me why I cannot gain permissions to ANY fat32 files. They are all registered as root and I've tried chmod, chown, used SUDO Nautius, etc and have never been able to change RW permissions. I usually get an Operation Not Permitted message anytime I try to change the permissions of any folder/file.

    Okay, here is the fstab, which I don't think I've modified since the installation. My computer has 2 drives, I'm trying to use a FAT32 partition on the second drive (HDB1) to share files between Windows and Ubuntu. I've had no success and it's driving me crazy. But I'm starting to hijack my own thread (if that's possible - fsck problems AND permission problems):

    # /etc/fstab: static file system information.
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    proc /proc proc defaults 0 0
    # /dev/hda5
    UUID=0a0a5c14-1600-45b7-b29a-47f8839b639f / ext3 defaults,errors=remount-ro 0 1
    # /dev/hdb7
    UUID=7d97fca5-264c-4a88-bf1e-d82b9d67ca63 /home ext3 defaults 0 2
    # /dev/hdb1
    UUID=459E-CBAD /home/share vfat defaults,utf8,umask=007,gid=46 0 1
    # /dev/hda1
    UUID=9307-4BE8 /media/hda1 vfat defaults,utf8,umask=007,gid=46 0 1
    # /dev/hda2
    UUID=D2E80495E80479CD /media/hda2 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
    # /dev/hdb5
    UUID=28B074E2B074B840 /media/hdb5 ntfs defaults,nls=utf8,umask=007,gid=46 0 1
    # /dev/hdb6
    UUID=459E-633F /media/hdb6 vfat defaults,utf8,umask=007,gid=46 0 1
    # /dev/hda6
    UUID=83096326-6a12-4172-a64c-48167fb97ce0 none swap sw 0 0
    /dev/hdc /media/cdrom0 udf,iso9660 user,noauto 0 0
    /dev/hdd /media/cdrom1 udf,iso9660 user,noauto 0 0
    /dev/ /media/floppy0 auto rw,user,noauto 0 0

    As I mentioned in the first post, I'm getting really good at partitioning, reinstalling, so I can easily start from scratch if necessary.

    Thanks for your help!

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    UUID=0a0a5c14-1600-45b7-b29a-47f8839b639f / ext3 defaults,errors=remount-ro 0 0
    UUID=7d97fca5-264c-4a88-bf1e-d82b9d67ca63 /home ext3 defaults 0 0
    set values to zero and check if it works.

    for FAT32 partition, set umask value to zero and remove gid.
    put # sign before its mount code and add new code.
    Code:
    #UUID=459E-CBAD /home/share vfat defaults,utf8,umask=007,gid=46 0 1
    /dev/hdb1  /home/share   vfat   defaults,umask=0 0 0
    save file and reboot.






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    10
    Thanks Casper.

    Changing the fstab eliminated the fsck at startup. That is certainly going to save me a lot of time at bootup. I'm going to have to figure out exactly what commands you had me change...

    I still cannot change ownership / permissions of the FAT32. I've tried chmod, chown, and sudo Nautilus to get the partition to belong to user drs1. The only thing I can accomplish is that in Nautilus I can actually get an option to change the permissions and can select another owner, but when I try to confirm it I still am not allowed. I guess that deserves another thread if I can't figure it out.

    Again, thanks for the help on the fsck problem.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    for ownership, add uid and gid in mount line in /etc/fstab file.
    Code:
    /dev/hdb1  /home/share   vfat   defaults,umask=0,uid=1000,gid=1000 0 0






    Casper
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    10
    Casper,

    Adding those items now allows me to mount the FAT32 and actually save edits. I thought I'd tried all this but apparently not. Thanks for allowing me to finally gain permissions over my files!

    Dave

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •