Find the answer to your Linux question:
Results 1 to 6 of 6
Hi I just installed madrake 9.2. I never got an option to create a flopy disk to boot in linux or something like this. While installing, at the end, during ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    8

    Can't get into Lilo nor Linux


    Hi
    I just installed madrake 9.2. I never got an option to create a flopy disk to boot in linux or something like this. While installing, at the end, during the summary, I selected /dev/hdb8/ for my boot loader, the partition I mounted as /boot/ while formating.
    Now, when I reboot, I still get into Windows boot loader. I added a line in boot.ini:
    multi(0)disk(0)rdisk(1)partition(\="Lilo"
    I was hoping that when clicking on it, I would get into Lilo from where I would be able select Linux?

    Or should I format Linux and start again and try to install Lilo in the MBR?
    Aliens243

  2. #2
    Linux Engineer kriss's Avatar
    Join Date
    Jun 2003
    Posts
    1,113
    You can just set up lilo to overwrite the MBR. Getting rid of that windows bootloader. It shouldn't be too much trouble setting it up. Add something like

    other=/dev/hda1
    label=windows
    table=/dev/hda

    to your lilo config.

    Good luck

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    8
    As soon as I can enter Lilo or Linux, I will try to make these change ,but for now, I still can't acess it. I tried an uninstall and a reinstall. This time, I choose the option write to MDR will installing the bootloader. After, in sumary, it was writen that the bootloader, Lilo, was installed to /dev/hdb/

    One thing is strange, I don't seem to have a hda according to mandrake partition tool. When I saw the partition, there was hdb, where I put my linux and where WinXP was already installed and hdc where is installed Win98. But no hda.

    Also, if there is a way to create a floppy disk that can work as a boot selector, that would be great.

    Finally, the only way that I have now to see the files in linux partition, since I never got able to enter linux yet, is with partition magic 8 browse feature... With this, I can't find a lilo.conf file or something like that.

    Thanks in advance
    Aliens243

  4. $spacer_open
    $spacer_close
  5. #4
    Just Joined!
    Join Date
    Apr 2004
    Posts
    8
    Humm, just found my lilo.conf file in /etc/
    I copied it with partition magic and I can READ it, but not edit it.

    But, I still can't enter it. I know it's possible to add a line to something like linux.bin in the boot.ini that direct to lilo, but I can't make that file linux.bin since I can't boot in linux. So, a boot disk that allow me to boot only once would be great.

    Aliens243

  6. #5
    Linux Engineer
    Join Date
    Sep 2003
    Location
    Knoxhell, TN
    Posts
    1,078
    you need to put lilo or GRUB (GRUB is better IMO) on the MBR of the first HDD... if you put it on the second, the BIOS will never see it.
    Their code will be beautiful, even if their desks are buried in 3 feet of crap. - esr

  7. #6
    Just Joined!
    Join Date
    Apr 2004
    Posts
    8
    Well, I finally was able to get into lilo after installing the bootloader in the mdr of hdc.
    But now, I see the windows, but can't acess them, but I'll work on this later, now, I'll explore linux.
    Thanks all
    Aliens243

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •