Find the answer to your Linux question:
Results 1 to 8 of 8
PLease help me.... i'm about to go insane w/ this. I've installed RH9 about 20x and each configuration I use to install the bootloader, it doesn't get detected. I've tried, ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2

    Can't Dual boot w/ XP - TRIED EVERYTHING


    PLease help me.... i'm about to go insane w/ this.

    I've installed RH9 about 20x and each configuration I use to install the bootloader, it doesn't get detected.

    I've tried, grub, lilo, w/ and w/out LBR, w/ an option of Primary Boot Partition or MBR, no matter what, after rebooting, it doesn't give me an option to boot into Linux.

    Also, my comp doesn't have a floppy so I can't make a boot disk.

    Thanks for any help possible.


    Additional Info.

    For the Install process, I use the auto partition, I've allocated about 3 gigs for it, and it does go through the installation perfectly, just doesn't want to give me an option to boot into it.

    If it matters, I'm using a Dell 4600 - I even changed the settings in the BIOS for OS install.

  2. #2
    Linux Newbie zdawg's Avatar
    Join Date
    Jan 2004
    Location
    Canada
    Posts
    218
    Do you have something like this in grub.conf
    Code:
    title=Windows XP
    rootnoverify &#40;hd0,<wherever M$ is>&#41;
    chainloader +1
    Me & Myself just ganged up on I....... Now We all have problems..and none of Us are speaking!
    bash-3.00$ uname -a
    SunOS sparky 5.11 OpenSolaris-swa sun4u sparc SUNW,Ultra-Enterprise

  3. #3
    Just Joined!
    Join Date
    Apr 2004
    Posts
    2
    How would I access the grub.conf file? I can't boot into linux.

  4. #4
    Linux Engineer
    Join Date
    Dec 2002
    Location
    New Zealand
    Posts
    766
    it doesnt give u a LINUX option??? what about a kernel version number eg 2.4.22-rh or somethign similar. if ur sure u cant boot into linux, boot off the install cd's into resuce mode and post /mnt/sysimage/etc/grub.conf

  5. #5
    don
    don is offline
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    101
    well this ones an old trick but could work...

    have your lilo installed on the first sector of ur boot partition( not the MBR).

    if u have a boot diskuse it to boot linux or use 'linux rescue' at the boot: prompt from the bootable install disc. either way drop into a shell with ur linux root partition on ur harddisk mounted.

    now assume hda1 is ur linux partition; use the following commands

    (have a dos bootable floppy at hand)

    Code:
    #dd if=/dev/hda1 of=/bootsect.lnx bs=512 count=1
    
    #mount /mnt/floppy
    
    #mcopy /bootsect.lnx a&#58;bootsect.lnx
                        or
    #cp /bootsect.lnx /mnt/floppy
    now with this file boot back to windows Xp, have the option to show hidden files and folders as well as show protected OS files enabled

    now on ur c:\ paste the bootsect.lnx file from the floppy

    then in ur C: dirve locate a file called boot.ini
    to it add this after the last line

    c:\bootsect.lnx = "Linux"

    save the file and reboot

    if all goes well u would get a windows startup menu with a second option linux.. on selecting this option it should boot into ur linux
    I\'m just a simple fisherman blessed with a lot of friends

  6. #6
    Linux Engineer Nerderello's Avatar
    Join Date
    Apr 2003
    Location
    North East England
    Posts
    1,190
    check out the tutorial section on GRUB HOWTO and you may be able to get around it.

    have fun

    Nerderello

    Use Suse 10.1 and occasionally play with Kubuntu
    Also have Windows 98SE and BeOS

  7. #7
    Just Joined!
    Join Date
    Apr 2004
    Posts
    10
    slim

    THer miight be a really easy way of fixing this.

    When you install linux you are installing the linux partition 'after' the windows partition correct. Now what might have happened is linux did not set the second partition as 'active' so it is booting in windows whose os loader is oblivious to linux. with a dos boot disk you can use fdisk to set the active partition. since you don't have a floppy drive, you can go into windows.

    Administrator's Tools, Computer Management, disk management, then right click on the linux partition and set it active. Be warned!!!!! if that isn't the problem then you will boot to a screwed up partition and can't set the active partition again since you don't have a floppy. You might want to ask if you can set the active partition from within linux rescue mode.

    HTH

  8. #8
    don
    don is offline
    Linux Newbie
    Join Date
    Apr 2004
    Posts
    101
    if lilo or grub is installed on the MBR, then ur linux need not be.. and should *NOT* be the active partition. Change your active partition only if GRUB is loaded on the first sector of your boot partion.
    I\'m just a simple fisherman blessed with a lot of friends

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •