Find the answer to your Linux question:
Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
Wierd stuff happened to me. Hoping this will help someone out there. So... I have an Inspiron E1505 that originally with Win XP preinstalled. I installed Suse Linux 10.2 and ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9

    Dell MediaDirect messed up my dual boot


    Wierd stuff happened to me. Hoping this will help someone out there.

    So... I have an Inspiron E1505 that originally with Win XP preinstalled. I installed Suse Linux 10.2 and was dual booting away merrily.

    So what happens? My 2 year old comes along and clicks this tiny "MediaDirect" button that I had no idea existed. It started up and initialized media direct and hey my dual boot did not work any more. -- always loads Windows XP - darn it!!

    I was quite leery of messing with the MBR and took the easy way out.

    Leave the windows MBR unchanged and add linux to boot.ini. This information is available elsewhere, but am pasting here for reference.

    Use a Linux rescue CD (I used the SUSE installation CD) to boot up SUSE.

    Login as root and run this command -
    dd if=/dev/sda3 of=linuxboot.lnx bs=512 count=1

    Replace /dev/sda3 with whatever partition you have for linux's /boot filesystem. Use "df" to find out.

    boot into windows XP, copy linuxboot.lnx to someplace in your windows partition (say C:\), and then edit C:\boot.ini to add following line in the end:

    C:\linuxboot.lnx="Linux"

    and you are set. If you want, you can decrease "timeout" at the start of boot.ini file. I set mine to 5 secs with linux as the default boot.

    Now reboot your computer, and you will see the option of booting into linux from windows Boot Menu.

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    The best way round this is to reinstall grub to the MBR. If it worked before, it will work again.

    what you need to do is this:

    Boot into linux. To do this, you have 2 options:
    - Boot the install CD,
    - Boot off the windows boot.ini setup.

    If booting from the Install CD, bhoose to boot from hard disk, and it should ask what partition to boot. Choose the /boot partition, and it should start loading suse. Services may well fail on boot, but ignore these. We just need a system we can reinstall grub from.

    If using the boot.ini method, all should be ok.

    Once SuSE is loaded open up YaST and get into the Bootloader Configuration.

    In here, select the "Overwrite MBR option" or similar named (cant remember exactly what it's called) and make it so that it WILL overwrite the MBR. Save changes, reboot, and you should be greeted by grub

    If you have any problems with this, post back.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9

    Problems with grub on MBR for Dell machines

    Writing this so it may warn other Dell users.

    Dual booting nirvana turned into hell after I had grub write the MBR.

    Because of the DELL crap, initially Windows refused to boot with the grub-written MBR.

    The Dell Utility partition (the first one on the disk) is a really a FAT32 partition disguised with "DE", hence windows thinks its an unknown partition and does not boot from it. Instead windows boots from the next NTFS/FAT32 partition.

    With the Grub written MBR, the Dell Utility partition was correctly identified as FAT32, which is not good, since Windows tries to boot from it.

    I tweaked grub's menu.lst to "hide" the Dell Utility Partition and Windows booted correctly - but it overwrote the MBR. Linux does not load now - since the Windows version of the MBR has Linux partitions marked as Amoeba (0x93 instead of 0x83).

    I think I need fdisk or something to unravel this mess. Any ideas?

  4. #4
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    you could edit menu.lst file and direct grub to boot from second partition instead of first ( Dell Utility ) partition.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  5. #5
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9

    Linux native partitions are now Amoeba

    Yes that's what I had done. Please read thru my previous post completely.

    Now MBR has Linux partitions marked as Amoeba (0x93 instead of 0x83). So menu.lst is not accessible.

  6. #6
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    i have read your last post. menu.lst or mbr has nothing to do with partition marking.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  7. #7
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9
    Sorry if I seemed abrupt

    Let me elaborate on the problem I face now.

    When I start up now, I am greeted by the Windows boot.ini menu - this is not too bad, since I have set up Suse as a boot option there. When I select that, instead of displaying the grub menu (as it used to before), now I get the grub> command prompt. This is unexpected, it doesn't seem to be reading my menu.lst at all?

    So I bravely continue on and at the grub prompt, try to boot my linux partition.

    root (fd0,2) // the third partition on my single disk is linux native bootable

    no fun.
    It tells me - "filesysystem type unknown, partiton type 0x93"

    0x93?!! that does not look right. My partition is linux native, the partition table should have 0x83 for an ext3 filesystem. right?

    What can I do?

  8. #8
    Super Moderator devils casper's Avatar
    Join Date
    Jun 2006
    Location
    Chandigarh, India
    Posts
    24,729
    root (fd0,2)
    fd0 represents Floppy Drive. download and install fs-driver in Windows. it will mount Linux Partition and assign Drive Letters. you will have read/write access in Linux Partitions.
    post the contents of /boot/grub/menu.lst and device.map files here.
    It is amazing what you can accomplish if you do not care who gets the credit.
    New Users: Read This First

  9. #9
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9
    Sorry, that was a typo.
    I meant hd0 (not fd0).

    I will try this and let you know.

  10. #10
    Just Joined!
    Join Date
    Jan 2007
    Posts
    9
    Thanks for trying to help...

    Just tried your suggestion but fs-driver fails to mount my linux partition. It tells me that the Amoeba filesystem is unsupported.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •