Find the answer to your Linux question:
Results 1 to 10 of 10
I have recorded a few things that caused me problems when installing Debian on a Compaq R3000 laptop. I hope it can be useful for people running into install-problems. See ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined!
    Join Date
    May 2004
    Posts
    1

    Experiences from Debbian installation


    I have recorded a few things that caused me problems when installing Debian on a Compaq R3000 laptop. I hope it can be useful for people running into install-problems.
    See the link:

    http://home.comcast.net/~bjorns/debbie.html

    Bjorn S.

  2. #2
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    Maybe you can submit it to http://www.linux-laptop.net/

  3. #3
    Just Joined!
    Join Date
    May 2004
    Posts
    3

    Linux R3000

    And I thought I was having problems because I couldn't get the wireless card working. I started out with Mandrake 10 though, so that probably eliminated like 50 hours of troubleshooting time. Mandrake install even resizes the windows partition to allow easy dual boot. After reading yours I was happy I chose this route. Anyway, I love my R3000, but the wireless card won't power on, and can't figure out how to get it to power on using the ndiswrapper. I have an external USB wireless that works great though... The built in broadcom wireless is unstable for me in windows.

    Oh and my sound buttons to control volume don't do anything yet, so sad. I think if I got these sound buttons to work maybe I could get that network button to do something too...

    But yea, sound, 3d accelerated video, touchpad, network, usb ... it works really nicely. Probably should use a distro that has the 2.6 kernel and X 4.3 though ready to go it you want to mess with it on this notebook.

  4. #4
    Just Joined!
    Join Date
    May 2004
    Posts
    3
    i have the same laptop but i can't get my sound card to work. could you explain how you got your sound card to work, what driver you used?

    thanks a lot

  5. #5
    Just Joined!
    Join Date
    May 2004
    Posts
    3

    Sound

    Right, this was one of the problems I had. I had to use the absolute newest release of the alsa drivers (http://www.alsa-project.org/) because the ones that were in the 2.6.3 kernel that Mandrake ships don't include the driver for this card. (The driver it needs is atiixp, and 1.0.4 detects it). The one in 1.0.3 didn't even work for me, but I was listening to mp3s last night with no problems, other than volume control buttons not working. Just need the driver and utilities (And maybe libraries). Just make them all and install it. I'm not at the notebook right now or I'd tell you more, that should ge you going though. Might be fixed in the release version of 10...

  6. #6
    Just Joined!
    Join Date
    May 2004
    Posts
    3
    great i'll try that tonight. as for the volume buttons i think you can get them to work pretty easily by using xmodmap. try googling for

    xmodmap linux volume control

    and you should be able to find lots of info. There's several ways to do it but they're all very straight forward.

    i found the following are pretty useful:
    http://www.x1000forums.com/index.php?showtopic=5127
    http://ozzzy.dhis.org/itouch.html
    http://web.ics.purdue.edu/~akovach/nx7000

  7. #7
    Just Joined!
    Join Date
    May 2004
    Posts
    3

    Sound Keys

    Cool, I'm betting that will work. I wonder if the wireless button also triggers some kind of keycode, or if it's something more internal to the system. So the 'only' thing that doesn't work now is the 54G broadcom wireless card, because the light doesn't turn on, so it doesn't seem like it's powered-up. (It turns on right when windows boots) I have a compaq ipaq usb that works great, so I know I know wireless is setup right. It probably works better since it has a real driver, but it hangs out of the computer. I haven't tried the linuxant driver yet, just using the ndiswrapper. I might try a few more things with that though.

    Thanks, it's a sweet computer, I'm bummed cause they're selling an Athlon 64 model of it now for the same price and I just bought it 2 months ago, I wanted that 64 ... Oh well ... (I have the P-4 model of the R3000)

  8. #8
    Just Joined!
    Join Date
    May 2004
    Posts
    3
    ya an athlon 64 would be sweet. i kind of didn't bother trying to get the internal wifi card to work and just got a pcmcia netgear ma401. it works great and its got a prism2 chipset so you can put it in monitor mode and do all that fun stuff.

  9. #9
    Just Joined!
    Join Date
    May 2004
    Posts
    1
    I have the R3050T and I was able to get the Broadcom 54g internal wifi to work using the latest ndiswrapper (don't know the version) and the bcmwl5a driver. When I modprobe ndiswrapper, it returns to its last power state. The button works from the console or from X. Search for that driver on google and you will see a place that has posted it as a tgz.

    As for sound, I still get no such device even after alsaconf finds the driver. lsmod shows them loaded and everything.

    kernel - 2.6.3
    alsa - 1.0.4
    udev - 025-r1
    ndiswrapper - 0.6-r1
    --edit--
    Forgot to mention that I am running Gentoo linux

    Dan

  10. #10
    Just Joined!
    Join Date
    May 2004
    Posts
    1

    Experiences from Debbian installation

    Here is a site I put together, and a link someone sent me:

    http://www1.uop.edu/~khughes/presario-r3120us/
    http://cmb.phys.cwru.edu/kisner/linux/compaq-r3000/

    I have sound working using alsa-0.9.8, just had to set up
    /etc/asound.conf, set up the default sound settings with
    alsamixer, and then run "alsactl store" to save them.

    As for the Broadcom WiFi, I can't locate any keycodes
    associated with it, but found it defintely has an effect
    under linux: it will disable the card from transmitting or
    receiving. However, if I turn off the card once it is
    configured, I have to run iwconfig again to restart it.

    The only things I haven't resolved yet are:
    * finding some way to use the wifi on/off button
    * getting CardBus cards to work in the PCMCIA adapter
    * getting suspend to RAM to work (not much hope there)

    Ken

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •