Find the answer to your Linux question:
Results 1 to 8 of 8
Hi ya, First I wish to thank whom may pay attention to this newbie question, surely duscussed 1000s of times. Brief resumee of what went wrong with my SuSE 9.0 ...
Enjoy an ad free experience by logging in. Not a member yet? Register.
  1. #1
    Just Joined! sbogus's Avatar
    Join Date
    May 2004
    Posts
    10

    Unable to Install SuSE 9.0 on two disk system


    Hi ya,
    First I wish to thank whom may pay attention to this newbie question, surely duscussed 1000s of times.

    Brief resumee of what went wrong with my SuSE 9.0 Installation:

    I have, after recent hardware upgrade, a Athlon 1.7 GHz, 768 MB RAM, CD-ROM+DVD Burner + 1x 40 GB HDD and 1x 160 GB HDD.

    Before this upgrade (it includes the second 160 GB HDD, the RAM and the DVD Burner) I used dual-boot system on the 40 GB HDD consisting of WinXP + SuSE 7.3, this works even now without any problems. As the worm Sasser killed my XP I decided to change it from XP to Win2k and to update my SuSE to at least 9.0.

    The problem:
    I decided to install the 9.0 version on the second HDD (hdb) and then after successful installation to reuse the whole hda for the Win2k installation (currently there's the 7.3 instalation and the dead corpse of WinXP). The installation packages of 9.0 are prepared on a mount point in my current 7.3 installation. The YaST2 setup works fine till the point of first reboot to finish the installation. Both GRUB and LILO fail to boot the installation from the hdb, furthermore GRUB just hangs with the error "GRUB: Hard Disk Error..." and this even the boot loaders are installed in the MBR. I've tried to put them in the boot partition of hdb but this also went wrong. Even specifying from the BIOS setup to boot from the second HDD (Primarys boot device is HDD-1), even then the installation will not boot.

    So, I used the Install CD (burned with the boot.iso image) to boot for the first time the new installation of SuSE 9.0 on the hdb drive. It went also wrong, because the kernel failed to load many modules (modprobe complains about missing "something" and "could not find something"), the peripherials failed to load too (no Ethernet, no USB -> no IP, no Mouse, no TCP/IP, no Internet)
    The strange case is that the YaST2 has recognized my hardware prety well and all was functional and operational while I was setting up the packages and preparing the installations, but during the first boot almost nothing was recognized by the loaded kernel...

    Please, If anyone has a tip or help suggestion, to tell me...
    Many thanks in advance!

    Kind regards,
    sbogus

  2. #2
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    I am not sure exactly what your problem is, but from what you have said, it could be that you have installed SuSE, then rescue'd Windows. I have a 120gig Hard disk (hdc) and a 160 gig hard disk (hda). If i was to do what you have done and updated everything i would install windows, then install linux, this works fine on my computer. I have installed Windows on the first partition of hda and given an extra partition on there for storing windows programs etc. Then i have an extended partition with my 4 linux partitions in it. (/boot, SWAP, /home and /) The second hard disk i simply use for storing music and my docs and everything.

    What i would suggest for you is to install windows and linux on hda and then use hdb for storing any data either through windows or linux.

    Hope this helps.
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  3. #3
    Just Joined! sbogus's Avatar
    Join Date
    May 2004
    Posts
    10

    RE: Unable to Install SuSE 9.0 on two disk system

    Thanks !
    As of my current state, I do have the suggested configuration: I have a SuSE 7.3 installation and a Windows XP installation (already dead, because of attack of the Sasser virus). Just the difference - my hda is 40 GB only and my hdb is 160 GB

    I can't boot the Windows XP installation because some of the system libraries are corupted and the boot process hangs. You're correct - I tried to rescue the XP installation, but I was unable to do this, because of missing Administrator password - weird but true, I've forgotten it. So there's no rescue'd XP installation - just a corpse.

    The 7.3 installtion can be boot-ed freely, the LILO application operates perfect. In order to install Windows again (for example as in your suggestion), I need to backup a large amount of data from the NTFS partition. Since I can't start XP I need either to copy this information on the other disk (hdb) or to burn it on a DVDs (it is about 6 GB data that need to be rescued from the dead XP installation). The SuSE 7.3 installation has no option to recoqnize my DVD burner, so my only chance is to install a newer Linux without to compromise the safety and the stability of the only one bootable instalation on hda.

    I just need to be able to install the newer Linux on the 160 GB disk and the old 40 GB disk to remain for the Windows installation.

    Thanks for the help.

    Kind regards,
    sbogus

  4. #4
    Just Joined!
    Join Date
    May 2004
    Posts
    9
    I seem to recall hearing a while back about some 80 gig HD limit in Linux. Perhaps Linux can't boot to a HD that big? Perhaps your BIOS can't handle a drive that big? Try installing winblows on it and see if your BIOS likes it. Try partitioning it and see if Linux likes it.

  5. #5
    Just Joined! sbogus's Avatar
    Join Date
    May 2004
    Posts
    10

    RE: Unable to Install SuSE 9.0 on two disk system

    Thanks cathyy,

    I forgot to mention, that my BIOS recoqnizes the HDD without problem, the max size of a HDD attached to one of the IDE channels is 512 GB, so my 160 GB falls far behind this boundary.

    Furthermore, the SuSE Installation (YaST2) recognizes this HDD also as 160 GB one and performs any partitioning operation on it - this means for me the disk is weel known to both BIOS and SuSE.

    I do not want to share this disk with Windows - it is for my Linux installation only, so installing Windows on hdb is not an option. Sure for test purposes I could dare to do this, but then I'm afraid it will mess up my current SuSE booting - it is the only one that boots without any troubles.

    Thanks!

    Kind regards,
    sbogus

  6. #6
    Linux Guru sdousley's Avatar
    Join Date
    Feb 2004
    Posts
    1,790
    As far as i know there is no limit on hard disk space! I have a 90 gig /home partition!! so if there is a limit, it's not 80 gig!!
    "I am not an alcoholic, alcoholics go to meetings"
    Registered Linux user = #372327

  7. #7
    Linux User
    Join Date
    Jan 2004
    Posts
    357
    Here's something that I found doing a google search on hard disk size limit
    http://www.win.tue.nl/~aeb/linux/Large-Disk-4.html
    As of now it looks like there is a 2 TiB limit with common BIOS and IDE disk's.

  8. #8
    Just Joined! sbogus's Avatar
    Join Date
    May 2004
    Posts
    10

    Some problems solved, others popped up

    Hi buddies,

    so this going to be my resumee on the past two or three days of battle with the SuSE 9.0 instalaltion.

    First of all, I got It working! , yes, all modprobe errors and peripherial fails are gone. For the missing modules I've just symlink-ed the kernel-specific "2.4.21-144" folder to the one requested by the boot loader - the one named "2.4.21-144-default". For the peripehrial fails it was critical to boot the installation's own kernel and not the one from the start CD, because the one in the start CD does not have any peripehials compiled in int, but rather than initializes separate modules when spawning the YaST2 setup application. That's the big difference! So now I have working Ethernet, PCI, USB, DHCP, DSL and whatever is comming thereafter. That were the good news, now continue with the bad ones...

    So there still be a problem with the bootloaders. According to the documentation of GRUB and LILO I relized that the bootloader errors, should be cause by wrong or missing harddisk geometry - GRUB didn't find the hdb at all and LILO didn't recognize the device hdb as having any partitions on it - thus the "Hard Disk Error..." error form the GRUB bootloader and the "L01 01 01..." error from the LILO one.

    I found out that the BIOS was hiding the HDD-1 drive because of the recognition mode set to "Disabled", I set this mode to "Auto" and it was there! Then all disk geometry was correct and the boot loaders were satisfied... But...

    I'm still be unable to boot from hdb, I must put GRUB or LILO in MBR of hda in order to boot the installation on hdb. How the heck I can set the bootloader so that it boots from the hdb disk?

    What settings/patitioning, bootloader configuration I should do, in order to be able to put the boot loader on hdb and then to boot directly from hdb?

    I use BIOS to set the boot sequence in the following order:
    1st = HDD-1 (this is my hdb)
    2nd = CDROM
    3rd = Floppy

    Putting the GRUB bootloader on MBR of the hdb causes the GRUB to freeze with this text on the screen "GRUB ", puting there the LILO bootloader causes the boot to freeze with this screen
    "99 99 99 99 ..." (a screen full of "99"s)
    Then puting a bootloader (GRUB or LILO does not matter) in the /boot section of the /root partiton of hdb renders the hdb to be non-bootable and BIOS proceeded directly to the next boot device in the boot sequence.
    Ohh yes, I put the "boot"-flag on that /root partition ("Activate the partiton as bootable"-option form the YaST2's Bootloader Setup Screen.

    So, what please can I do in order to make it working directly from the hdb disk?

    Many thanks in advance.

    Kind regards,
    sbogus

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •